Bug 987386 - CLI: cannot delete organization with dot in name
CLI: cannot delete organization with dot in name
Status: CLOSED DUPLICATE of bug 973907
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Mike McCune
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 06:38 EDT by Ales Dujicek
Modified: 2014-01-27 09:05 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 07:15:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Dujicek 2013-07-23 06:38:32 EDT
Description of problem:

deletion of organization with name containing dot fails

org create --name .com
Successfully created org [ .com ]
org delete --name .com
Resource not found on the server

org create --name acme.com
Successfully created org [ acme.com ]
org delete --name acme.com
operation failed

Version-Release number of selected component (if applicable):
katello-1.4.2-18.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-agent-1.4.3-1.git.1.24fe511.el6.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-configure-1.4.3-16.el6sat.noarch
katello-glue-pulp-1.4.2-18.el6sat.noarch
katello-all-1.4.2-18.el6sat.noarch
katello-cli-common-1.4.2-8.el6sat.noarch
ruby193-rubygem-foreman-katello-engine-0.0.8-6.el6sat.noarch
signo-katello-0.0.19-1.el6sat.noarch
katello-glue-elasticsearch-1.4.2-18.el6sat.noarch
katello-configure-foreman-1.4.3-16.el6sat.noarch
katello-foreman-all-1.4.2-18.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-cli-1.4.2-8.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-2.el6_4.noarch
katello-common-1.4.2-18.el6sat.noarch
katello-selinux-1.4.3-3.el6sat.noarch
katello-glue-candlepin-1.4.2-18.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.3-6.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch


How reproducible:
always

Steps to Reproduce:
1. org create --name acme.com
2. org delete --name acme.com
3. org create --name .com
4. org delete --name .com

Actual results:


Expected results:


Additional info:
Comment 1 Ales Dujicek 2013-08-01 07:15:35 EDT
duplicate of 973907 which is more general

*** This bug has been marked as a duplicate of bug 973907 ***

Note You need to log in before you can comment on or make changes to this bug.