Bug 987411 - Current openssl version does not support 'Next Protocol Negotiation'.
Current openssl version does not support 'Next Protocol Negotiation'.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openssl (Show other bugs)
6.4
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomas Mraz
Hubert Kario
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 07:02 EDT by Craig Taylor
Modified: 2013-11-21 04:23 EST (History)
1 user (show)

See Also:
Fixed In Version: openssl-1.0.1e-11.el6
Doc Type: Enhancement
Doc Text:
Feature: As a result of rebase to openssl-1.0.1e upstream the Next Protocol Negotiation extension of TLS protocol is now supported by OpenSSL. This extension allows to negotiate which application protocol will be used by the application already during the TLS handshake.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 04:23:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Craig Taylor 2013-07-23 07:02:16 EDT
Description of problem:
Current openssl version does not support 'Next Protocol Negotiation'.

Version-Release number of selected component (if applicable):
openssl-1.0.0

Additional info:
Available in upstream version 1.0.1
NPN is required for HTTP2.0(SPDY)
Comment 4 Hubert Kario 2013-09-10 10:16:45 EDT
The man page fix is not present in openssl-1.0.1e-10.el6

The patch is available here: https://bugzilla.redhat.com/attachment.cgi?id=780726 as an attachment for bug 924250.
Comment 5 Tomas Mraz 2013-09-12 07:32:21 EDT
Fixed.
Comment 8 Craig Taylor 2013-09-20 11:48:12 EDT
I'm assuming that we'll see TLSv1.2 and GCM ciphers come through with this version: Any idea of the release details, is this likely RHEL 6.5 or an independent errata update?

Thank you...
Comment 9 Craig Taylor 2013-10-25 10:24:31 EDT
I notice this version is in the 6.5 beta...
Comment 10 Tomas Mraz 2013-10-25 10:34:24 EDT
Yes, it is planned to be released in RHEL-6.5.
Comment 11 errata-xmlrpc 2013-11-21 04:23:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1585.html

Note You need to log in before you can comment on or make changes to this bug.