Bug 987438 - eclipse-ptp 7.0.x is FTBFS on ARM
eclipse-ptp 7.0.x is FTBFS on ARM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse-ptp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2013-07-23 07:37 EDT by Peter Robinson
Modified: 2013-08-02 17:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: eclipse-ptp-7.0.1-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-02 17:51:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2013-07-23 07:37:28 EDT
All 7.0.x builds fail. Previously 6.x at least built OK. Links to builds.

http://arm.koji.fedoraproject.org/koji/packageinfo?packageID=10712


[INFO] Resolving class path of MavenProject: org.eclipse.ptp:org.eclipse.ptp.rdt.sync.git.ui:1.0.0-SNAPSHOT @ /builddir/build/BUILD/org.eclipse.ptp-7a7225fc8470b8ec4bc614ff9110d8045fa20a52/rdt/org.eclipse.ptp.rdt.sync.git.ui/pom.xml
[ERROR] Internal error: java.lang.NullPointerException: -> [Help 1]
org.apache.maven.InternalErrorException: Internal error: java.lang.NullPointerException: 
	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:168)
	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
	at org.fedoraproject.maven.connector.Main.main(Main.java:54)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:414)
	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:357)
Caused by: java.lang.NullPointerException: 
	at org.eclipse.tycho.core.osgitools.EquinoxResolver.assertResolved(EquinoxResolver.java:268)
	at org.eclipse.tycho.core.osgitools.EquinoxResolver.newResolvedState(EquinoxResolver.java:70)
	at org.eclipse.tycho.core.osgitools.OsgiBundleProject.getResolverState(OsgiBundleProject.java:252)
	at org.eclipse.tycho.core.osgitools.OsgiBundleProject.resolveClassPath(OsgiBundleProject.java:160)
	at org.eclipse.tycho.core.resolver.DefaultTychoDependencyResolver.resolveProject(DefaultTychoDependencyResolver.java:122)
	at org.eclipse.tycho.core.maven.TychoMavenLifecycleParticipant.afterProjectsRead(TychoMavenLifecycleParticipant.java:98)
	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:274)
	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
	... 11 more
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/InternalErrorException
error: Bad exit status from /var/tmp/rpm-tmp.WAWHkN (%build)
    Bad exit status from /var/tmp/rpm-tmp.WAWHkN (%build)
RPM build errors:
Child return code was: 1
EXCEPTION: Command failed. See logs for output.
Comment 1 Krzysztof Daniel 2013-07-23 07:49:48 EDT
This is an ARM JVM issue where it does incorrect optimization. To fix it, it is necessary to exclude org/eclipse/tycho/core/osgitools/EquinoxResolver,newState from (I guess) HotSpot optimizations. Just add this command before invoking maven/tycho:

export MAVEN_OPTS="-XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState ${MAVEN_OPTS}"
Comment 2 Krzysztof Daniel 2013-07-23 08:24:47 EDT
This is the scratch build I've started:
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=2010099
Comment 3 Krzysztof Daniel 2013-07-23 10:26:50 EDT
Build fail because of the broken build stack.
Comment 4 Fedora Update System 2013-07-25 03:41:44 EDT
eclipse-ptp-7.0.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/eclipse-ptp-7.0.1-2.fc19
Comment 5 Krzysztof Daniel 2013-07-25 03:48:42 EDT
A scratch build [1] succeeded so I'm running a regular one now [2].
[1] http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=2018420
[2] http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=2018587
Comment 6 Krzysztof Daniel 2013-07-25 04:01:43 EDT
And we are done:
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=2018587
Comment 7 Fedora Update System 2013-07-25 20:37:46 EDT
Package eclipse-ptp-7.0.1-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-ptp-7.0.1-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13662/eclipse-ptp-7.0.1-2.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-08-02 17:51:24 EDT
eclipse-ptp-7.0.1-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.