Bug 987467 - Cut-and-paste with mouse no longer works
Cut-and-paste with mouse no longer works
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 08:46 EDT by Zdenek Kabelac
Modified: 2013-08-23 07:32 EDT (History)
6 users (show)

See Also:
Fixed In Version: gnome-settings-daemon-3.9.90-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-23 07:32:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2013-07-23 08:46:03 EDT
Description of problem:

Gnome-terminal as of my todays rawhide upgrade no longer allows to insert any text via  mouse -  so no longer  cut&paste work being possible.
(And it works everywhere else - i.e. konsole, firefox...)


Version-Release number of selected component (if applicable):
gnome-terminal-3.8.4-1.fc20.x86_64


How reproducible:


Steps to Reproduce:
1. mark text
2. hit middle mouse button
3.

Actual results:
nothing happens

Expected results:
paste happens

Additional info:
Comment 1 Tomáš Bžatek 2013-07-23 11:32:11 EDT
https://git.gnome.org/browse/vte/commit/?h=vte-0-34&id=2b6efd6aa23eb576bb788c3dbba50f59895d21e0

Still hoping to have the option on by default as per X standards.
Comment 2 Zdenek Kabelac 2013-07-23 11:44:25 EDT
So I've add "gtk-enable-primary-paste = 1" to my:

~/.config/gtk-3.0/settings.ini 


which has restored NORMAL behavior.

So now I just hope, it's been just a mistake, that default is Off.
Comment 3 Zdenek Kabelac 2013-07-23 11:52:32 EDT
Changing to gtk3 component, since it's not related to gnome-terminal.

Since it's my last used tool from the Gnome, I've not had a chance to notice problems in other apps.

gtk3-3.9.8-1.fc20.x86_64
Comment 4 Kalev Lember 2013-08-23 07:32:49 EDT
Middle click paste is now enabled by default again at upstream and I've backported this to the Fedora packages as well.

Fixed in gtk3-3.9.12-1.fc20 and gnome-settings-daemon-3.9.90-2.fc20

Note You need to log in before you can comment on or make changes to this bug.