Bug 987470 - CLI - deletion changeset promote fails
CLI - deletion changeset promote fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Eric Helms
Hayk Hovsepyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 08:51 EDT by Hayk Hovsepyan
Modified: 2014-04-24 13:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:08:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hayk Hovsepyan 2013-07-23 08:51:32 EDT
Description of problem:
When we create deletion type changeset on some environment, and add into it content view which was already promoted, and try to promote that changeset, it will fail.

Version-Release number of selected component (if applicable):
katello-cli-1.4.2-1.git.131.cacfdea.el6.noarch
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
elasticsearch-0.19.9-7.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.951.091dd45.el6.noarch
katello-all-1.4.2-1.git.951.091dd45.el6.noarch
Katello-Katello-Configuration-KatelloClient-1.1-50.noarch
openldap-2.4.23-31.el6.x86_64
python-ldap-2.3.10-1.el6.x86_64
Katello-Katello-Installation-ConfigureRepos-1.7-3.noarch
katello-repos-1.4.2-1.el6.noarch
ruby193-rubygem-net-ldap-0.3.1-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
pulp-rpm-handlers-2.1.2-0.3.beta.el6.noarch
ruby193-rubygem-ldap_fluff-0.2.2-1.el6.noarch
katello-cli-common-1.4.2-1.git.131.cacfdea.el6.noarch
pulp-selinux-2.1.2-0.3.beta.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
pulp-rpm-plugins-2.1.2-0.3.beta.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-glue-pulp-1.4.2-1.git.951.091dd45.el6.noarch
katello-1.4.2-1.git.951.091dd45.el6.noarch
candlepin-0.8.17-1.el6.noarch
candlepin-tomcat6-0.8.17-1.el6.noarch
katello-agent-1.4.3-1.git.1.24fe511.el6.noarch
signo-0.0.9-1.el6.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
Katello-Katello-Installation-KatelloNightly-1.0-13.noarch
pulp-server-2.1.2-0.3.beta.el6.noarch
katello-common-1.4.2-1.git.951.091dd45.el6.noarch
katello-glue-candlepin-1.4.2-1.git.951.091dd45.el6.noarch
candlepin-selinux-0.8.17-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
candlepin-cert-consumer-cfseserver2.usersys.redhat.com-1.0-1.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch

How reproducible:
always

Steps to Reproduce:
1. Create 2 environments "Dev" (prior=Library) and "Test"(prior=Dev), zoo repo, sync it.
2. Create content definition and add zoo repo into it. Create some filter with rule to include some package (or errata)  for example "lion" and publish and promote content view to Dev environment.
3. Promote the same content view to Test environment as well.
4. Create deletion type changeset on Test environment. Add content view into it.
5. Apply changest, and you will see that it shows error "promotion failed", which is bug

Actual results:
error is shown that "promotion failed".

Expected results:
no error should be shown as content view was already promoted to that environment, so deletion will be ok

Additional info:
the same problem when in content view filter we have errata instead of package
Comment 1 RHEL Product and Program Management 2013-09-17 00:22:02 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 4 Eric Helms 2013-10-08 14:37:30 EDT
Tested this on latest and everything seemed to be working fine for me. Setting to POST to have this verified.
Comment 5 Hayk Hovsepyan 2013-10-10 08:17:03 EDT
Verified on revision:

signo-0.0.22-2.el6sat.noarch
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
foreman-1.3.0-15.el6sat.noarch
katello-cli-common-1.4.3-19.el6sat.noarch
openldap-2.4.23-31.el6.x86_64
pulp-nodes-common-2.3.0-0.17.beta.el6sat.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-0.8.25-1.el6sam.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-glue-pulp-1.4.6-29.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-agent-1.4.4-3.el6sat.noarch
Katello-Katello-Installation-Satellite6Latest-1.0-12.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
katello-qpid-broker-key-pair-1.0-1.noarch
foreman-proxy-1.3.0-3.el6sat.noarch
foreman-postgresql-1.3.0-15.el6sat.noarch
katello-cli-1.4.3-19.el6sat.noarch
pulp-selinux-2.3.0-0.17.beta.el6sat.noarch
python-ldap-2.3.10-1.el6.x86_64
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-configure-foreman-proxy-1.4.5-10.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.17.beta.el6sat.noarch
pulp-nodes-parent-2.3.0-0.17.beta.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
signo-katello-0.0.22-2.el6sat.noarch
katello-glue-candlepin-1.4.6-29.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-1.4.6-29.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
katello-configure-foreman-1.4.5-10.el6sat.noarch
katello-foreman-all-1.4.6-29.el6sat.noarch
Katello-Katello-Configuration-KatelloClient-1.1-53.noarch
candlepin-cert-consumer-ares.usersys.redhat.com-1.0-1.noarch
katello-repos-1.4.2-1.el6.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
katello-configure-1.4.5-10.el6sat.noarch
pulp-server-2.3.0-0.17.beta.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.17.beta.el6sat.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
katello-common-1.4.6-29.el6sat.noarch
katello-glue-elasticsearch-1.4.6-29.el6sat.noarch
katello-all-1.4.6-29.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
pulp-rpm-handlers-2.3.0-0.17.beta.el6sat.noarch
Katello-Katello-Installation-HammerCLI-1.0-7.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
Comment 6 Bryan Kearney 2014-04-24 13:08:01 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.