Bug 987475 - python-glanceclient 0.5.1 is broken with latest python-keystoneclient 0.2.0
python-glanceclient 0.5.1 is broken with latest python-keystoneclient 0.2.0
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: python-glanceclient (Show other bugs)
el6
All Linux
urgent Severity high
: ---
: ---
Assigned To: Jakub Ruzicka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 08:56 EDT by Darren Birkett
Modified: 2013-07-26 07:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 07:33:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darren Birkett 2013-07-23 08:56:13 EDT
Description of problem:

python-glanceclient, as it is currently packaged, has a requirement of python-keystoneclient >=0.1.2,<0.2.  

# cat /usr/lib/python2.6/site-packages/python_glanceclient-0.5.1-py2.6.egg-info/requires.txt

prettytable>=0.6,<0.7
python-keystoneclient>=0.1.2, <0.2
warlock<2

Since python-keystoneclient in epel is now at 0.2.0 as of 12 June, this breaks use of the glance client.

Editing this file manually to remove the <0.2.0 makes everything work.

Version-Release number of selected component (if applicable):

python-glanceclient 0.5.1
python-keystoneclient 0.2.0

How reproducible:

every time

Steps to Reproduce:
1. enable epel repo
2. install openstack. 
3. use python-glanceclient (glance command) to interact with the glance repo)

Actual results:

python stacktrace

Traceback (most recent call last):
  File "/usr/bin/glance", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2659, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: python-keystoneclient>=0.1.2,<0.2

Expected results:

glance client works fine with no stacktrace
Additional info:

This is a simple packaging bug.  A one line change in the requirements.txt file will fix this.
Comment 1 Pádraig Brady 2013-07-23 09:14:13 EDT
That requirements file is redundant and problematic in the presence of RPM.
Like other openstack/python packages we should do the following in %prep

  rm -rf {test-,}requirements.txt tools/{pip,test}-requires

thanks!
Comment 2 Jakub Ruzicka 2013-07-26 06:50:39 EDT
Actually, there is new fixed version in updates.

If you would be so kind and push it, Padraig:

https://admin.fedoraproject.org/updates/python-glanceclient-0.8.0-2.el6
Comment 3 Pádraig Brady 2013-07-26 07:33:15 EDT
Ouch missed that one.
Submitted now, should go live in a day or so

Note You need to log in before you can comment on or make changes to this bug.