Bug 987496 - [RHEVM] [vdsm] Migration Issue Ovirt 3.0 -> 3.3 (missing alias in devices)
[RHEVM] [vdsm] Migration Issue Ovirt 3.0 -> 3.3 (missing alias in devices)
Status: CLOSED DUPLICATE of bug 988065
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Nobody's working on this, feel free to take it
virt
: Triaged
Depends On: 999801
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 09:54 EDT by Martin Pavlik
Modified: 2015-09-22 09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 08:57:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log_collector (5.14 MB, application/x-xz)
2013-07-23 09:54 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2013-07-23 09:54:59 EDT
Created attachment 777331 [details]
log_collector

Description of problem:


Version-Release number of selected component (if applicable):
rhevm is4 (3.3)
vdsm-4.11.0-89.git8bf916a.el6.x86_64.rpm
vdsm-4.9-113.4.el6_3.x86_64.rpm

How reproducible:


Steps to Reproduce:
1. set RHEVM 3.3 environment
2. set up DC 3.0 with Cluster 3.0
3. add host with vdsm 3.3 (vdsm-4.12.XXX) to the cluster
4. add host with vdsm 3.0 (vdsm-4.9-113.XXX) to the cluster
5. create VM on 3.0 host, run it and try to migrate to 3.3 host

Actual results:
migration fails 

Expected results:
migration successfull

Additional info:

RHEVM used - is4 (3.3)
Data Center / Cluster 3.0
Host 1 = RHEL - 6Server - 6.4.0.4.el6 - vdsm-4.11.0-89.git8bf916a.el6 (3.3, is4)
Host 2 = RHEV Hypervisor - 6.2 - 20120320.0.el6_2 - vdsm-4.9-112.6.el6_2 (3.0)
3.0 host - dell-06 - source
Thread-275::ERROR::2013-07-04 13:31:35,129::vm::176::vm.Vm::(_recover) vmId=e068fa00-eb43-4c4d-8b24-e3ceffa58ff3::migration destination error: Unexpected exception
Thread-275::ERROR::2013-07-04 13:31:35,211::vm::231::vm.Vm::(run) vmId=e068fa00-eb43-4c4d-8b24-e3ceffa58ff3::Traceback (most recent call last):
File "/usr/share/vdsm/vm.py", line 223, in run
File "/usr/share/vdsm/libvirtvm.py", line 400, in _startUnderlyingMigration
RuntimeError?: migration destination error: Unexpected exception
3.3 host - dell-05 - destination
Thread-10561::ERROR::2013-07-04 15:31:36,219::vm::2029::vm.Vm::(_startUnderlyingVm) vmId=e068fa00-eb43-4c4d-8b24-e3ceffa58ff3::The vm start process failed
Traceback (most recent call last):
File "/usr/share/vdsm/vm.py", line 2007, in _startUnderlyingVm
self._waitForIncomingMigrationFinish()
File "/usr/share/vdsm/vm.py", line 3251, in _waitForIncomingMigrationFinish
self._connection.lookupByUUIDString(self.id),
File "/usr/lib64/python2.6/site-packages/vdsm/libvirtconnection.py", line 112, in wrapper
ret = f(*args, kwargs)

File "/usr/lib64/python2.6/site-packages/libvirt.py", line 2838, in lookupByUUIDString
if ret is None:raise libvirtError('virDomainLookupByUUIDString() failed', conn=self)
libvirtError: Domain not found: no domain with matching uuid 'e068fa00-eb43-4c4d-8b24-e3ceffa58ff3'
Comment 1 Michal Skrivanek 2013-08-20 05:31:49 EDT
can you re-try after bug 988065 is fixed now? It's a possible dupe
Comment 2 Michal Skrivanek 2013-09-05 08:57:28 EDT

*** This bug has been marked as a duplicate of bug 988065 ***

Note You need to log in before you can comment on or make changes to this bug.