Bug 98751 - Error with non-descriptive message trying to run up2date -d -u --nox
Error with non-descriptive message trying to run up2date -d -u --nox
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-08 10:48 EDT by Glen A. Foster
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-29 10:50:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen A. Foster 2003-07-08 10:48:42 EDT
Description of problem: While trying to run up2date for AS2.1/x86 using an
enterprise account for HP, I get the following repeatable transaction output:

[root@rhn-x86 root]# up2date -d --nox -u

Fetching package list for channel: redhat-advanced-server-i386...
########################################

Fetching Obsoletes list for channel: redhat-advanced-server-i386...
########################################

Fetching rpm headers...
########################################

Testing package set / solving RPM inter-dependencies...
########################################
XFree86-4.1.0-49.RHEL.i386. ########################## Done.
There was a fatal error communicating with the server.  The message was:
Error

... kinda hard to tell what the real problem is, looks like there's some sort of
unexpected errno being returned and perror() has no string to print.

Version-Release number of selected component (if applicable):
# rpm -q up2date 
up2date-2.8.45-1.2.1AS

How reproducible: 100% (always)
Comment 1 Glen A. Foster 2003-12-29 10:50:04 EST
Closing, as I'm unable to reproduce this. Thanks for fixing whatever
it was you changed...

Note You need to log in before you can comment on or make changes to this bug.