This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 98752 - 'emacs -nw', backspace, and screen
'emacs -nw', backspace, and screen
Status: CLOSED DUPLICATE of bug 11294
Product: Fedora
Classification: Fedora
Component: screen (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Reed
Brock Organ
:
Depends On:
Blocks: 91357
  Show dependency treegraph
 
Reported: 2003-07-08 10:53 EDT by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2003-07-08 10:53:47 EDT
Description of problem:
Backspace inside emacs -nw inside screen (inside gnome-terminal) broke again. :-(

Version-Release number of selected component (if applicable):
emacs-21.3-6
screen-3.9.15-9
gnome-terminal-2.2.1-4

How reproducible:
100%

Steps to Reproduce:
1. Start gnome terminal
2. screen
3. emacs -nw
4. Type 'abc' and backspace to beginning of buffer

Actual results:
Backspace doesn't remove the character to the left of the cursor.

Expected results:
Works as expected. :-)

Additional info:

This used to work not long ago.
Comment 1 Tim Waugh 2003-08-14 10:30:04 EDT
Seems to be fixed now.
Comment 2 Ben Levenson 2004-05-20 12:43:42 EDT
reopening:
<Backspace> does not delete characters in vim with screen-4.0.2-2.
This worked in 3.9.15-11.
I'm not so great at parsing .screenrc, but this seems to resolve
the issue:
"bindkey -d -k kb stuff \010"
Comment 3 David Balažic 2004-06-18 07:41:25 EDT
Duplicate of bug 11294 ?
Comment 4 Daniel Reed 2004-06-18 09:58:42 EDT

*** This bug has been marked as a duplicate of 11294 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:56:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.