Bug 987528 - Unable to get gear quota info
Unable to get gear quota info
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 11:04 EDT by Oleg Fayans
Modified: 2016-11-30 19:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 14:08:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oleg Fayans 2013-07-23 11:04:29 EDT
Description of problem:

When I request the gear quota info I am getting the following error message:

$ rhc app-show myapp --gear quota
Unable to connect to gear 65fac008f37711e2aa2322000a1df718@65fac008f37711e2aa2322000a1df718-ofayans.dev.rhcloud.com
Unable to connect to gear b198c8f8f37111e2aa2322000a1df718@myapp-ofayans.dev.rhcloud.com
Gear                             Cartridges              Used Limit
-------------------------------- ---------------------- ----- -----
b198c8f8f37111e2aa2322000a1df718 python-2.7 haproxy-1.4 error  1 GB
65fac008f37711e2aa2322000a1df718 postgresql-8.4         error  1 GB

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. install the latest rhc client
2. install net-ssh-multi gem
3. create an app
4. rhc app-show [app_name] --gear quota

Actual results:


Expected results:


Additional info:
$ gem q --local | grep ssh
net-ssh (2.6.8, 2.6.6, 2.2.1)
net-ssh-gateway (1.2.0, 1.1.0)
net-ssh-multi (1.2.0, 1.1)

$ rhc --version
rhc 1.12.1
Comment 1 Wei Sun 2013-07-23 23:20:16 EDT
Check this bug on devenv_3544,rhc build from devenv_3544,can not reproduce this bug.

[wsun@dhcp-8-229 ~]$ rhc app-show py27s --gear quota
Password: *
Gear                     Cartridges               Used Limit
------------------------ ---------------------- ------ -----
51ef46cb2c7ba00a19000005 python-2.7 haproxy-1.4 180 KB  1 GB
51ef471c2c7ba0105b000001 postgresql-8.4          46 KB  1 GB

[wsun@dhcp-8-229 ~]$ rhc app-show py27s --gears quota
Password: *
Gear                     Cartridges               Used Limit
------------------------ ---------------------- ------ -----
51ef46cb2c7ba00a19000005 python-2.7 haproxy-1.4 180 KB  1 GB
51ef471c2c7ba0105b000001 postgresql-8.4          46 KB  1 GB

[wsun@dhcp-8-229 ~]$ gem q --local|grep ssh
net-ssh (2.6.6)
net-ssh-gateway (1.2.0)
net-ssh-multi (1.2.0)
Comment 2 Fabiano Franz 2013-07-26 14:08:39 EDT
I was also unable to reproduce. Please check if the bug is still reproducible and in that case reopen the bug with more info (Origin, Online or Enterprise? Which version in case of Enterprise?).

ffranz@ffranz ~$ gem q --local | grep ssh
net-ssh (2.6.8)
net-ssh-gateway (1.2.0)
net-ssh-multi (1.2.0)
ffranz@ffranz ~$ rhc --version
rhc 1.12.1
ffranz@ffranz ~$ rhc app-show commafeed --gear quota
Gear                     Cartridges               Used Limit
------------------------ ---------------------- ------ -----
000000000000000000000000 jbosseap-6.0 mysql-5.1 0.9 MB  1 GB

Note You need to log in before you can comment on or make changes to this bug.