Bug 987553 - PassengerRoot is ignored for ruby cartridges
PassengerRoot is ignored for ruby cartridges
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 12:00 EDT by Brenton Leanhardt
Modified: 2015-05-14 19:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 08:46:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brenton Leanhardt 2013-07-23 12:00:01 EDT
Description of problem:
In my gear's ruby/etc/conf.d/openshift.conf I tried the following:

How reproducible:


Steps to Reproduce:
1. Create a Ruby cartridge
2. Modify ruby/etc/conf.d/openshift.conf and set the PassengerRoot to 'NotUsed'
3. stop and start the gear

Actual results:
The gear continues to work.  To avoid confusion I am suggesting we change the PassengerRoot value in our ruby cartridge to 'NativelyPackaged'.  This is because in the passenger's ext/common/ResourceLocator.h we are hitting the "natively packaged" logic.  Our binaries are shipped as part of rubygem-passenger-native.


Additional info:

Pull Request incoming...
Comment 1 openshift-github-bot 2013-07-23 19:07:28 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/b773a196943a3d1cb1e86092784cbda9bac2d702
Bug 987553 - PassengerRoot is ignored for ruby cartridges
Comment 2 Meng Bo 2013-08-23 06:49:44 EDT
Checked on devenv-stage_452,

The value of PassengerRoot has been changed to "NativelyPackaged" for ruby cartridges.
And the ruby cartridge works fine.

Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.