Bug 987556 - seahorse-nautilus does not encrypt file
seahorse-nautilus does not encrypt file
Status: CLOSED DUPLICATE of bug 981580
Product: Fedora
Classification: Fedora
Component: seahorse-nautilus (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rui Matos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 12:08 EDT by Mark Harfouche
Modified: 2013-07-24 11:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 11:39:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Harfouche 2013-07-23 12:08:16 EDT
Description of problem:
Cannot encrypt files using right-click with seahorse nautilus

Version-Release number of selected component (if applicable):
nautilus 3.8.2-1.fc19 x86_64
seahorse-nautilus 3.8.0-1.fc19 x86_64
How reproducible:
100%

Steps to Reproduce:
1. Install seahorse-nautilus `sudo yum install -y seahorse-nautilus`
2. Open seahorse, create yourself a PGP key
3. Make a dummy text file.
4. Open the directory in Nautilus.
5. Right click on the file
6. Select "encrypt file"
7. Chose the PGP key you just created.
8. Press OK

Actual results:
No encrypted file created

Expected results:
The encrypted file should have been created
Comment 1 Stef Walter 2013-07-24 03:50:55 EDT
Could you run the following command and see if there are any warnings or messages output?

seahorse-tool --encrypt ~/.bashrc

Thank you.
Comment 2 Mark Harfouche 2013-07-24 11:37:35 EDT
Hi, Thank you for looking at this.

I copy pasted the error message below. I also tried creating a new user and following the instructions I gave and got the same error message (usually this fixes half the bugs).


seahorse-tool --encrypt ~/.bashrc

** (seahorse-tool:20105): WARNING **: couldn't load all the keys (1/2) from GPGME

(seahorse-tool:20105): GLib-WARNING **: GChildWatchSource: Exit status of a child process was requested but ECHILD was received by waitpid(). Most likely the process is ignoring SIGCHLD, or some other thread is invoking waitpid() with a nonpositive first argument; either behavior can break applications that use g_child_watch_add()/g_spawn_sync() either directly or indirectly.
Comment 3 Stef Walter 2013-07-24 11:39:10 EDT

*** This bug has been marked as a duplicate of bug 981580 ***

Note You need to log in before you can comment on or make changes to this bug.