Bug 98756 - SSH Connections Hang/Timeout on large amounts of text output under redhat linux 8.0
SSH Connections Hang/Timeout on large amounts of text output under redhat lin...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
http://www.openssh.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-08 11:43 EDT by Nick Lange
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-15 17:53:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
list of packages for our particular install (3.59 KB, text/plain)
2003-07-08 11:43 EDT, Nick Lange
no flags Details

  None (edit)
Description Nick Lange 2003-07-08 11:43:01 EDT
On a minimized redhat 8.0 install commands like strace, or untarring a large
file will cause the session to slow to a crawl and freeze. I suspect that this
is actually any command with large amounts of output but cannot confirm.
Furthermore, we have several redhat linux boxes with other package sets
including this that do not exhibit this behaviour. Therefore, I suspect that the
package may be the cause... but exactly which I do not know.
(I've tried switching from en_US.utf-8 to en_US to no avail)

We are using Putty .53b as a client; however, I can not confirm this to be a bug
with their software.

SSH Packages:
openssh-3.4p1-2
openssh-server-3.4p1-2
openssh-clients-3.4p1-2


example command:
strace ssh image@<host> cat somefile

the strace will begin and you can watch the output slow to a crawl, and finally
 stop after an unknown period of time (in a couple cases).

I have 


Additional info:
See attached package list.
Comment 1 Nick Lange 2003-07-08 11:43:48 EDT
Created attachment 92800 [details]
list of packages for our particular install

package list
Comment 2 Nick Lange 2003-07-15 17:53:59 EDT
The Bug is in PuTTY, not OpenSSH.

rpm -qail done from within a putty terminal direct induces the lockup.
rpm -qail done through a known good server connecting the the problem server w/
openssh client works flawlessly.
rpm -qial from console of known good server to problem server works flawlessly.
Will follow up with the putty team.

Thanks,
nick

Note You need to log in before you can comment on or make changes to this bug.