Bug 98757 - xfs dies if Big5 fonts missing
Summary: xfs dies if Big5 fonts missing
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL: http://bugs.xfree86.org/cgi-bin/bugzi...
Whiteboard:
Keywords: MoveUpstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-08 15:45 UTC by Craig Ruff
Modified: 2007-04-18 16:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-17 10:49:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Craig Ruff 2003-07-08 15:45:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Description of problem:
I happened to access a web site that caused the xfs server to die with a SEGV
(according to strace).  It turns out that the web site
(http://www.upgradeware.com/tw/index.htm) used a Taiwan Big5 font, which I did
not have installed.  Installing them (taipeifonts-1.2-23) stopped xfs from dying.

Version-Release number of selected component (if applicable):
XFree86-xfs-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1. Start X without the Big5 fonts installed.
2. Use mozilla to access http://www.upgradeware.com/tw/index.htm, for example.
3. xfs dies, mozilla hangs.  Restarts of X fail because xfs is not running.

Additional info:

Comment 1 Mike A. Harris 2003-07-10 14:24:21 UTC
Please report this in the XFree86 upstream bugzilla located at
http://bugs.xfree86.org and update this report with a URL linking to the
upstream report for tracking purposes.

Thanks.

Comment 2 Craig Ruff 2003-07-10 14:47:33 UTC
XFree86 bug URL: http://bugs.xfree86.org/cgi-bin/bugzilla/show_bug.cgi?id=493

Comment 3 Mike A. Harris 2003-07-10 18:01:59 UTC
Thanks, setting bug state to UPSTREAM to track in the upstream bugzilla.

Comment 4 Mike A. Harris 2003-07-17 10:49:03 UTC
The upstream bug report has been closed WORKSFORME.  Without ability to reproduce
freely and without further debug info such as a backtrace, I'm unable to
investigate this any deeper.  If you can provide any more debugging information,
please continue to add it to the upstream bug report as I'm CC'd there.

Comment 5 Craig Ruff 2003-07-17 13:12:52 UTC
Of course, once I decided things seemed to be working, it failed again.
This time it was with the Big5 fonts installed.  It may be to some
TrueType fonts I have installed, but I have not yet been able to
narrow down which one.  This is the stack trace from the failure point:

#0  0x4207c45c in memcpy () from /lib/tls/libc.so.6
#1  0x4009401e in FTGetEnglishName () from /usr/X11R6/lib/libXfont.so.1
#2  0x40090b10 in FTRemap () from /usr/X11R6/lib/libXfont.so.1
#3  0x400926a6 in FTRemap () from /usr/X11R6/lib/libXfont.so.1
#4  0x40092cf0 in FTRemap () from /usr/X11R6/lib/libXfont.so.1
#5  0x4004f759 in FontFileOpenFont () from /usr/X11R6/lib/libXfont.so.1
#6  0x0805077f in strcpy ()
#7  0x08050e0b in strcpy ()
#8  0x0804b7db in strcpy ()
#9  0x0804a3b6 in strcpy ()
#10 0x0804a022 in strcpy ()
#11 0x420156a4 in __libc_start_main () from /lib/tls/libc.so.6



Note You need to log in before you can comment on or make changes to this bug.