Bug 987572 - mpmath: please package python 3 version
mpmath: please package python 3 version
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-mpmath (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Zbigniew Jędrzejewski-Szmek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 982759
  Show dependency treegraph
 
Reported: 2013-07-23 13:01 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2013-09-15 20:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: python-mpmath-0.17-8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-15 20:32:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
simplify spec file a bit in preparation for subsequent changes (1.71 KB, patch)
2013-08-06 17:06 EDT, Zbigniew Jędrzejewski-Szmek
no flags Details | Diff
add mpmath-python3 and make new release (4.81 KB, patch)
2013-08-06 17:07 EDT, Zbigniew Jędrzejewski-Szmek
no flags Details | Diff
simplify spec file a bit in preparation for subsequent changes (1.37 KB, patch)
2013-08-07 10:13 EDT, Zbigniew Jędrzejewski-Szmek
no flags Details | Diff
add mpmath-python3 and make new release (5.26 KB, patch)
2013-08-07 10:18 EDT, Zbigniew Jędrzejewski-Szmek
no flags Details | Diff

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2013-07-23 13:01:08 EDT
Description of problem:
Fedora now only has python2 version of mpmath. Lack of python 3 version of mpmath is holding sympy back (#982759), which in turn makes ipython3 less useful than it could be. Please consider packaging mpmath also for python 3.3

Last released mpmath-0.17 supports python 3.2, but fails one test related to hashing in python 3.3. Updated upstream in https://github.com/fredrik-johansson/mpmath seems to work fine with python 3.3. The tests pass, modulo one trivial bug which I've now sent a pull request to fix (https://github.com/fredrik-johansson/mpmath/pull/5). All in all, it seems that there shouldn't be trouble with mpmath under Python 3.
Comment 1 Susi Lehtola 2013-07-23 13:30:22 EDT
Feel free to apply for comaintainership to fix the problem.
Comment 2 Zbigniew Jędrzejewski-Szmek 2013-08-05 12:37:47 EDT
(In reply to Susi Lehtola from comment #1)
> Feel free to apply for comaintainership to fix the problem.
With pleasure. I've joing the packagers group, and I'm formally requesting comaintainership. My fedora pkgdb uid is 'zbyszek'.

I'll post the spec patch here for review...
Comment 3 Zbigniew Jędrzejewski-Szmek 2013-08-06 17:06:14 EDT
Created attachment 783515 [details]
simplify spec file a bit in preparation for subsequent changes
Comment 4 Zbigniew Jędrzejewski-Szmek 2013-08-06 17:07:17 EDT
Created attachment 783516 [details]
add mpmath-python3 and make new release
Comment 5 Susi Lehtola 2013-08-07 07:16:00 EDT
Patches should be prefixed with the package name, i.e.

0001-fix-py3.2-hash-tests.patch -> mpmath-py3-hashtest.patch

**

The patches don't really seem to be conforming to

http://fedoraproject.org/wiki/Packaging:Python
Comment 6 Susi Lehtola 2013-08-07 07:30:14 EDT
Also, python3 support needs to be conditionalized, since I want to use the same spec in the epel branches as well.
Comment 7 Zbigniew Jędrzejewski-Szmek 2013-08-07 10:13:46 EDT
Created attachment 783940 [details]
simplify spec file a bit in preparation for subsequent changes
Comment 8 Zbigniew Jędrzejewski-Szmek 2013-08-07 10:18:24 EDT
Created attachment 783951 [details]
add mpmath-python3 and make new release
Comment 9 Susi Lehtola 2013-08-07 10:25:31 EDT
I think you still need to follow
 http://fedoraproject.org/wiki/Packaging:Python#Building_more_than_once
because the build phase is now run only with python2.

Also, please be sure when you send diffs that the reference spec is the current one, and not one you've already toyed with. E.g. attachments #783515 and #783940 are pretty much meaningless.
Comment 10 Zbigniew Jędrzejewski-Szmek 2013-08-07 11:47:56 EDT
(In reply to Susi Lehtola from comment #9)
> I think you still need to follow
>  http://fedoraproject.org/wiki/Packaging:Python#Building_more_than_once
> because the build phase is now run only with python2.
All the build phase does, is copy sources to a subdir. And the sources are python2/python3 compatible, and this build directory works fine for both python2 and python3 installation.

> Also, please be sure when you send diffs that the reference spec is the
> current one, and not one you've already toyed with. E.g. attachments #783515
> and #783940 are pretty much meaningless.
Updated.

v2 (attached above):
- patch is prefixed with package name
- BuildRequires:python-devel is back
- replaced BuildRequires:python3 with python3-devel
- python3 is conditionalized

v3 (attached below):
- rebase onto latest master

All unit tests pass under python 2 and 3. The doctests under python3 have some failures, but it appears that those are just formatting issues (floating-point precision and having the full exception name in tracebacks, and print statements somewhere in the docstrings).

I think all Packaging:Python guidelines are now met.
Thank you for the acls, I'll give them a bit of more local testing, and push.

scratch builds:
rawhide: http://koji.fedoraproject.org/koji/taskinfo?taskID=5790206
f19: http://koji.fedoraproject.org/koji/taskinfo?taskID=5790201
f18: http://koji.fedoraproject.org/koji/taskinfo?taskID=5790207
Comment 11 Susi Lehtola 2013-08-07 14:00:26 EDT
OK, then the update is pretty much good to go on my behalf.
Comment 12 Fedora Update System 2013-09-06 04:48:11 EDT
python-mpmath-0.17-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-mpmath-0.17-8.fc19
Comment 13 Fedora Update System 2013-09-06 21:28:39 EDT
Package python-mpmath-0.17-8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-mpmath-0.17-8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16008/python-mpmath-0.17-8.fc19
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2013-09-15 20:32:00 EDT
python-mpmath-0.17-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.