Bug 987591 - Reserve static uid/gid for openstack-savanna
Reserve static uid/gid for openstack-savanna
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 14:11 EDT by Matthew Farrellee
Modified: 2013-07-24 08:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 02:35:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Farrellee 2013-07-23 14:11:46 EDT
I'd like to reserve uid/gid 167, the next unallocated id close to the OpenStack block in https://git.fedorahosted.org/cgit/setup.git/tree/uidgid, for the savanna user/group with a homedir of /var/lib/savanna. 

openstack-savanna package review is at https://bugzilla.redhat.com/show_bug.cgi?id=986615
Comment 1 Ondrej Vasik 2013-07-24 02:35:20 EDT
Filing bugzilla against setup is no longer the correct way. See http://fedoraproject.org/wiki/Packaging:UsersAndGroups#Soft_static_allocation . 

Closing NOTABUG for now, I'm sorry, but I'm no longer allowed to allocate ids myself. Feel free to reopen or file new bugzilla, once approved by FPC (reference the decision then).
Comment 2 Matthew Farrellee 2013-07-24 07:35:34 EDT
FYI, I've created https://fedorahosted.org/fpc/ticket/322

The wiki is devoid of information about how to structure the fpc ticket (what component, any cc, any prio, defect / enhancement, version, milestone, etc). Please have a look at tell me if it's correctly filed.
Comment 3 Ondrej Vasik 2013-07-24 08:01:14 EDT
Thanks for info, I will add myself to cc of that ticket. FPC will likely require justification why static id is needed. Other than that, I'm not aware of the "official structure" template for this kind of tickets, it is pretty recent change - actually I think this is only the second uid/gid allocation request since the change of the process.

Note You need to log in before you can comment on or make changes to this bug.