Bug 987594 - Unable to attach subscriptions with Cores, RAM and Instance based to a custom distributor
Unable to attach subscriptions with Cores, RAM and Instance based to a custom...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity high
: rc
: 1.3
Assigned To: Tom McKay
sthirugn@redhat.com
: Triaged
Depends On:
Blocks: sam13-tracker 995939
  Show dependency treegraph
 
Reported: 2013-07-23 14:24 EDT by sthirugn@redhat.com
Modified: 2013-10-01 07:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 995939 (view as bug list)
Environment:
Last Closed: 2013-10-01 07:14:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Manifest used (111.78 KB, application/zip)
2013-08-20 16:24 EDT, sthirugn@redhat.com
no flags Details

  None (edit)
Description sthirugn@redhat.com 2013-07-23 14:24:38 EDT
Description of problem:
Unable to attach subscriptions with Cores, RAM and Instance based to a custom distributor

Version-Release number of selected component (if applicable):
* candlepin-0.8.17-1.el6.noarch
* candlepin-selinux-0.8.17-1.el6.noarch
* candlepin-tomcat6-0.8.17-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-1.4.2-1.git.940.fda5b8f.el6.noarch
* katello-all-1.4.2-1.git.940.fda5b8f.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.131.cacfdea.el6.noarch
* katello-cli-common-1.4.2-1.git.131.cacfdea.el6.noarch
* katello-common-1.4.2-1.git.940.fda5b8f.el6.noarch
* katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.940.fda5b8f.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.940.fda5b8f.el6.noarch
* katello-glue-pulp-1.4.2-1.git.940.fda5b8f.el6.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
* pulp-rpm-plugins-2.1.2-0.3.beta.el6.noarch
* pulp-selinux-2.1.2-0.3.beta.el6.noarch
* pulp-server-2.1.2-0.3.beta.el6.noarch



How reproducible:
Always

Steps to Reproduce:
1. Create a portal distributor with subscriptions using Cores, RAM and Instance based
2. Download the manifest and upload to katello. Review the subscriptions using Content -> Subscriptions -> Red Hat Subscriptions - to make sure all Cores, RAM and Instance based subscriptions are displayed.
3. Create a distirbutor in katello using Content -> Subscriptions -> Subscription Manager Applications -> +New Distributor
4. Select the newly created distributor 
5. Review the Available Subscriptions on the right pane

Actual results:
Any subscription which has limitations on Cores, RAM or Instance based subscriptions are not displayed.  (All other subscriptions like 'socket' based are displayed)

Expected results:
All the Cores, RAM and Instance based subscriptions are displayed

Additional info:
Comment 2 Tom McKay 2013-07-30 10:01:34 EDT
Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 0e78225df9030a3d8126e7a32770840e5634206e
      https://github.com/Katello/katello/commit/0e78225df9030a3d8126e7a32770840e5634206e
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2013-07-30 (Tue, 30 Jul 2013)


@distributor.facts = {'system.certificate_version' => '3.2'} 

Forcing version to 3.2 for now
Comment 3 Bryan Kearney 2013-08-02 14:52:18 EDT
SNAP0 contains these bug fixes. Moving to ON_QA.
Comment 4 sthirugn@redhat.com 2013-08-14 14:07:15 EDT
Failed.  I had a Cores subscription which is not pulled in to available subscriptions for my distributor.

Packages tested:
* candlepin-0.8.19-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.19-1.el6sam.noarch
* candlepin-tomcat6-0.8.19-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-5.el6sat.noarch
* katello-cli-common-1.4.3-5.el6sat.noarch
* katello-common-1.4.3-6.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
* katello-headpin-1.4.3-6.el6sam_splice.noarch
* katello-headpin-all-1.4.3-6.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 6 Bryan Kearney 2013-08-20 15:33:41 EDT
We believe this should be delivered already.
Comment 7 sthirugn@redhat.com 2013-08-20 16:22:10 EDT
Failed for the same reason as Comment 4 above.

Version Tested:
* candlepin-0.8.20-1.el6sam.noarch
* candlepin-cert-consumer-cloud-qe-21.idm.lab.bos.redhat.com-1.0-1.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.20-1.el6sam.noarch
* candlepin-tomcat6-0.8.20-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-7.el6sat.noarch
* katello-cli-common-1.4.3-7.el6sat.noarch
* katello-common-1.4.3-8.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
* katello-headpin-1.4.3-8.el6sam_splice.noarch
* katello-headpin-all-1.4.3-8.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noar
Comment 8 sthirugn@redhat.com 2013-08-20 16:24:18 EDT
Created attachment 788635 [details]
Manifest used
Comment 10 Tom McKay 2013-08-26 09:48:49 EDT
Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 027d74332917297a2ca8d3b0acf44d86511ffd2f
      https://github.com/Katello/katello/commit/027d74332917297a2ca8d3b0acf44d86511ffd2f
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2013-08-26 (Mon, 26 Aug 2013)
Comment 12 sthirugn@redhat.com 2013-08-29 11:31:17 EDT
VERIFIED.

Version Tested:
* candlepin-0.8.24-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.24-1.el6sam.noarch
* candlepin-tomcat6-0.8.24-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-9.el6sat.noarch
* katello-cli-common-1.4.3-9.el6sat.noarch
* katello-common-1.4.3-11.el6sam_splice.noarch
* katello-configure-1.4.4-3.el6sat.noarch
* katello-glue-candlepin-1.4.3-11.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-11.el6sam_splice.noarch
* katello-headpin-1.4.3-11.el6sam_splice.noarch
* katello-headpin-all-1.4.3-11.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 14 errata-xmlrpc 2013-10-01 07:14:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.