Bug 987660 - /usr/bin/cups-config: line 55: test: too many arguments
/usr/bin/cups-config: line 55: test: too many arguments
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 16:07 EDT by Orion Poplawski
Modified: 2014-08-07 23:06 EDT (History)
2 users (show)

See Also:
Fixed In Version: cups-1.6.3-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-07 23:06:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2013-07-23 16:07:14 EDT
Description of problem:

$ /usr/bin/cups-config --serverbin
/usr/bin/cups-config: line 55: test: too many arguments
/usr/lib/cups

This is because of:

# Fetch libdir from gnutls's pkg-config script.  This is a bit
# of a cheat, but the cups-devel package requires gnutls-devel anyway.
libdir=`pkg-config --variable=libdir gnutls`
imagelibdir=`pkg-config --variable=libdir gnutls`

but cups-devel doesn't require gnutls-devel anymore.

Version-Release number of selected component (if applicable):
cups-devel-1.6.3-3.fc19.x86_64
Comment 1 Tim Waugh 2013-07-24 04:37:51 EDT
Oops, thanks for spotting this.

Note You need to log in before you can comment on or make changes to this bug.