Bug 987689 - [Doc] Document secure deployment via Foreman
Summary: [Doc] Document secure deployment via Foreman
Status: CLOSED DUPLICATE of bug 1010308
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: Unspecified Unspecified
medium
high
Target Milestone: z3
: 4.0
Assignee: Bruce Reeler
QA Contact: ecs-bugs
URL:
Whiteboard:
Keywords: Documentation, FutureFeature, Triaged, ZStream
Depends On: 1010308
Blocks: RHOS40RFE
TreeView+ depends on / blocked
 
Reported: 2013-07-23 21:42 UTC by Adam Young
Modified: 2016-04-26 14:51 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-20 07:52:22 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Young 2013-07-23 21:42:19 UTC
Deploy RHOS  with RedHat IdM for authentication, IdM and Centralized key/certificate management

Comment 1 Dmitri Pal 2013-07-23 21:49:49 UTC
Follow reference architecture document to be published.

Comment 3 Adam Young 2013-07-25 19:25:49 UTC
Some of the things that should be tested are

1.  Use Kerberos to provide SSO to the Hardware/Servers running OpenStack
2.  Use Kerberos/LDAP for Keystone
3.  Use Dogtag to provision certificates for HTTPS, Postgresql, AMQP
4.  Use Kerberos/GSSAPI to Authenticate for Postgresql, AMQP

Comment 6 Martin Lopes 2014-03-16 23:57:59 UTC
This bug is being assigned to Bruce Reeler, who is now the designated docs specialist for Identity Service.

Comment 7 Bruce Reeler 2014-03-19 02:08:01 UTC
Deployment guide obsolete. Changing component to ICG.

Comment 8 Bruce Reeler 2014-03-20 07:52:22 UTC
This bug has been incorporated in BZ1010308, so I am closing this bug as a duplicate as there is more info in BZ1010308.

*** This bug has been marked as a duplicate of bug 1010308 ***


Note You need to log in before you can comment on or make changes to this bug.