Bug 987693 - [thin] Thin snapshot creation fails when pool created with --zero n
Summary: [thin] Thin snapshot creation fails when pool created with --zero n
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Zdenek Kabelac
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-23 21:55 UTC by Marian Csontos
Modified: 2013-11-21 23:26 UTC (History)
10 users (show)

Fixed In Version: lvm2-2.02.100-1.el6
Doc Type: Bug Fix
Doc Text:
Code regression caused corruption of thin snapshot, if the underlaying pool was created without zeroing (which is non-default option used in some particular cases). As a consequence the first 4KB in the snapshot could have been invalided. This regression has been fixed.
Clone Of:
Environment:
Last Closed: 2013-11-21 23:26:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1704 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2013-11-20 21:52:01 UTC

Description Marian Csontos 2013-07-23 21:55:20 UTC
Description of problem:
Can not create thin snapshots when pool is created with --zero n.

Version-Release number of selected component (if applicable):
lvm2-2.02.99-0.367.el6_4.x86_64 (upstream)

How reproducible:
100%

Steps to Reproduce:

    #!/bin/bash
    VG=vg
    POOL=pool
    ORIGIN=origin
    SNAP=snap
    
    OPTS="--zero n"
    
    lvcreate --thin -L 2G $OPTS ${VG}/${POOL}
    lvcreate --virtualsize 500M --thinpool ${VG}/${POOL} -n ${ORIGIN}
    lvcreate -s /dev/${VG}/${ORIGIN} -n ${SNAP} -vvvv &> lvcreate-s-failed.$(date "+%Y%m%d-%H%M%S").out

Actual results:
Last lvcreate fails as snap device is not activated and can not be written to:
    /dev/vg/snap: not found: device not cleared
    Aborting. Failed to wipe snapshot exception store.

Expected results:
Pass

Additional info:

Comment 2 Zdenek Kabelac 2013-07-23 23:19:19 UTC
Fixed regression introduced in 2.02.94 upstream with:
https://www.redhat.com/archives/lvm-devel/2013-July/msg00210.html


Using snapshots on non-zeroed thin pool lead to cleared 4KB header of such snapshot.

Comment 4 Nenad Peric 2013-08-14 11:44:52 UTC
Verified with:

lvm2-2.02.100-1.el6.x86_64



 #!/bin/bash
    VG=vg
    POOL=pool
    ORIGIN=origin
    SNAP=snap
    
    OPTS="--zero n"
    
    lvcreate --thin -L 2G $OPTS ${VG}/${POOL}
    lvcreate --virtualsize 500M --thinpool ${VG}/${POOL} -n ${ORIGIN}
    lvcreate -s /dev/${VG}/${ORIGIN} -n ${SNAP} -vvvv &> lvcreate-s-failed.$(date "+%Y%m%d-%H%M%S").out

Executed script:

Logical volume "lvol0" created
Logical volume "pool" created
Logical volume "origin" created

Comment 5 errata-xmlrpc 2013-11-21 23:26:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1704.html


Note You need to log in before you can comment on or make changes to this bug.