Bug 98770 - rpmbuild for php-4.2.2-17.2.src.rpm fails on RH9
Summary: rpmbuild for php-4.2.2-17.2.src.rpm fails on RH9
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-08 18:08 UTC by Jeff Thompson
Modified: 2007-04-18 16:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-10 13:27:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpmbuild output (31.04 KB, text/plain)
2003-07-08 18:10 UTC, Jeff Thompson
no flags Details

Description Jeff Thompson 2003-07-08 18:08:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705; .NET CLR 1.1.4322)

Description of problem:
Hi, I'm trying to rebuild the php rpm's from php-4.2.2-17.2.src.rpm and it 
fails. See attachment for rpmbuild output.


Version-Release number of selected component (if applicable):
 php-4.2.2-17.2.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. rpm -ivh  php-4.2.2-17.2.src.rpm
2. cd /usr/src/redhat/SPECS
3. rpmbuild -ba php.spec
    

Actual Results:  ./configure fails, see attachment for rpmbuild output.

Expected Results:  Successful build of RPM's and SRPM

Additional info:

Comment 1 Jeff Thompson 2003-07-08 18:10:13 UTC
Created attachment 92804 [details]
rpmbuild output

Comment 2 Joe Orton 2003-07-08 21:09:25 UTC
You've upgraded to autoconf 2.57, right?

Comment 3 Jeff Thompson 2003-07-08 21:54:15 UTC
Joe, yes, that's correct... I'm currently at autoconf-2.57-3.5 and automake-
1.7.4-1.7.

Comment 4 Joe Orton 2003-07-10 13:27:23 UTC
That's not a supported configuration then, sorry - lots of RHL9 packages will
fail to rebuild if you upgrade to the Raw Hide autoconf or libtool RPMs.

You can take the php-4.2.2-cxx.patch from the Raw Hide php package and add it in
if you want get this one working.

Comment 5 Jeff Thompson 2003-07-10 15:04:37 UTC
Thanks Joe, I'll review my options and either fallback to previous versions of 
autoconf and libtool, etc and/or pursue the option of grabbing that patch you 
referred to...

I didn't intentionally install anything from rawhide, but I recently started 
using a tool called "apt", which I suspect grabbed something as a prereq, 
etc...

Since you mentioned that rawhide updates are not supported per se, are the 
updates found on updates.redhat.com fully supported? In other words, if I 
fallback to versions of packages on updates.redhat.com, will I be in a 
supported configuration?

Thanks

Comment 6 Joe Orton 2003-07-10 15:17:48 UTC
Yes, if you stick to updates from updates.redhat.com (or from Red Hat Network
using "up2date") then you'll remain in a supported configuration.


Note You need to log in before you can comment on or make changes to this bug.