Bug 987701 - Various Mesa Examples are rendered upside down
Summary: Various Mesa Examples are rendered upside down
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mesa
Version: 6.3
Hardware: Unspecified
OS: Unspecified
urgent
medium
Target Milestone: rc
: 6.6
Assignee: Dave Airlie
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 994246 1039098
TreeView+ depends on / blocked
 
Reported: 2013-07-23 22:50 UTC by Jesus Cortez
Modified: 2018-12-03 19:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 04:52:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1376 normal SHIPPED_LIVE xcb-util, xorg-x11-drivers, and mesa bug fix and enhancement update 2014-10-14 01:11:03 UTC
FreeDesktop.org 66213 None None None Never
Red Hat Knowledge Base (Solution) 538853 None None None Never

Description Jesus Cortez 2013-07-23 22:50:36 UTC
Description of problem:
When running some of the Mesa examples, we found that some examples are being rendered upside down.

readpix : press f, and notice the text / images being drawn upside down
tessdemo: Clicking on the mouse places a point on the correct X coordinate, but on the opposite Y coordinate
winpos: running the example, the images are upside down.

Version-Release number of selected component (if applicable):
9.0

How reproducible:
always

Steps to Reproduce:
1. Navigate to the Mesa examples (/usr/lib/mesa)
2. Run one of the following examples, and observe the behavior:
readpix : press f, and notice the text / images being drawn upside down
tessdemo: Clicking on the mouse places a point on the correct X coordinate, but on the opposite Y coordinate
winpos: running the example, the images are upside down.

Actual results:
The 3D images will be rendered upside down

Expected results:
The 3D images should not be upside down

Additional info:
I'm not sure whether this is a bug in Mesa or Red Hat, so I've created a bug report for both projects (https://bugs.freedesktop.org/show_bug.cgi?id=66213)

Comment 2 RHEL Product and Program Management 2013-10-14 03:02:48 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 Dave Airlie 2013-11-13 02:58:14 UTC
fix has been debugged, checking upstream, so devel ack.

Comment 5 Dave Airlie 2013-11-21 09:18:48 UTC
link to fix upstream also.
http://cgit.freedesktop.org/mesa/mesa/commit?id=a43b49dfb13dc7e6d2d6d7ceee892077038d7102

Comment 9 Dave Airlie 2013-12-03 05:14:10 UTC
mesa-9.2-0.6.el6 is built in brew.

Comment 18 errata-xmlrpc 2014-10-14 04:52:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1376.html


Note You need to log in before you can comment on or make changes to this bug.