Bug 987765 - password with '&' does not works
password with '&' does not works
Status: CLOSED DUPLICATE of bug 855117
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ricci (Show other bugs)
6.4
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Chris Feist
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 02:46 EDT by Martin Lazar
Modified: 2013-09-17 10:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-12 10:17:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 198233 None None None Never

  None (edit)
Description Martin Lazar 2013-07-24 02:46:44 EDT
Description of problem:
If the password for ricci user contains the ampersand character, the ccs utility does not works.

Version-Release number of selected component (if applicable):
ricci-0.16.2-63.el6.x86_64
ccs-0.16.2-63.el6.x86_64


How reproducible:
# echo 'ricci:aAa' | chpasswd
# rm -rf ~/.ccs
# ccs -h localhost -p 'aAa' --getversion
85
(it works)

root@app2.du2 ~ # echo 'ricci:a&a' | chpasswd
root@app2.du2 ~ # rm -rf ~/.ccs
root@app2.du2 ~ # ccs -h localhost -p 'aAa' --getversion
Unable to authenticate with ricci node, please check password.
(wrong password, the password was changed, expected result)

root@app2.du2 ~ # time ccs -h localhost -p 'a&a' --getversion
Error: no ricci tag in ricci response
real	2m0.302s
(the right password, BUG!)
Comment 3 Jan Pokorný 2013-08-12 10:17:43 EDT
Duplicate of [bug 855117] (and possibly also [bug 855121]).
Also see [1] (just FYI, thread start is at [2], not easy to find due
to split across the months in the mailman archives).

[1] https://www.redhat.com/archives/linux-cluster/2012-September/msg00019.html
[2] https://www.redhat.com/archives/linux-cluster/2012-August/msg00091.html

*** This bug has been marked as a duplicate of bug 855117 ***

Note You need to log in before you can comment on or make changes to this bug.