This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 9878 - rpm -Va reports files missing even though they are there
rpm -Va reports files missing even though they are there
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-01 02:14 EST by Stephen Rasku
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-01 02:14:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Rasku 2000-03-01 02:14:49 EST
For example, rpm reports:

missing    /usr/doc/lesstif-0.89.4/AUTHORS
missing    /usr/doc/lesstif-0.89.4/BUG-REPORTING
missing    /usr/doc/lesstif-0.89.4/COPYING
missing    /usr/doc/lesstif-0.89.4/COPYING.LIB
missing    /usr/doc/lesstif-0.89.4/CREDITS
missing    /usr/doc/lesstif-0.89.4/CURRENT_NOTES
missing    /usr/doc/lesstif-0.89.4/ChangeLog
missing    /usr/doc/lesstif-0.89.4/FAQ
missing    /usr/doc/lesstif-0.89.4/KNOWN_BUGS
missing    /usr/doc/lesstif-0.89.4/NEWS
missing    /usr/doc/lesstif-0.89.4/NOTES
missing    /usr/doc/lesstif-0.89.4/README
missing    /usr/doc/lesstif-0.89.4/RELEASE-POLICY
missing    /usr/doc/lesstif-0.89.4/TODO
missing    /usr/doc/lesstif-0.89.4/example.motifbind
missing    /usr/doc/lesstif-0.89.4/motifbind.sun+linux

However:

ls /usr/doc/lesstif-0.89.4 reveals:

AUTHORS        CREDITS        KNOWN_BUGS  RELEASE-POLICY
BUG-REPORTING  CURRENT_NOTES  NEWS        TODO
COPYING        ChangeLog      NOTES       example.motifbind
COPYING.LIB    FAQ            README      motifbind.sun+linux

I am running rpm 3.0.4-0.38.  I ran rpm as a regular user and the files are
not accessible by that user.  However, if I do an ls as the user, it knows
that the files are there but it lists them all as "Permission denied".

rpm should:

1. Display a more useful error message such as "inaccessible" (or "unknown"
if "inaccessible" is too long), or
2. dissallow the user to run -Va unless they are root.
Comment 1 Jeff Johnson 2000-08-10 01:33:23 EDT
Because of the use of rpm -Va in numerous scripts, it's not possible to change
the output
format to, for example, supply a more informative error message. Either run rpm
-Va as root
or fix the permissions of the doc files in question.

Note You need to log in before you can comment on or make changes to this bug.