Bug 987832 - failed to add ovirtmgmt bridge when the host has static ip
failed to add ovirtmgmt bridge when the host has static ip
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: 3.4.0
Assigned To: Antoni Segura Puimedon
Martin Pavlik
network
: Triaged
Depends On:
Blocks: 1024889
  Show dependency treegraph
 
Reported: 2013-07-24 05:14 EDT by Sandro Bonazzola
Modified: 2014-04-01 00:53 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-31 08:32:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifcfg-em1 before adding the host (326 bytes, text/plain)
2013-07-24 05:15 EDT, Sandro Bonazzola
no flags Details
ifcfg-em1 after adding the host (97 bytes, text/plain)
2013-07-24 05:16 EDT, Sandro Bonazzola
no flags Details
ifcfg-ovirtmgmt created after adding the host (72 bytes, text/plain)
2013-07-24 05:16 EDT, Sandro Bonazzola
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 23329 None None None Never

  None (edit)
Description Sandro Bonazzola 2013-07-24 05:14:31 EDT
Description of problem:
adding a newly installed host configured with static IP fails to configure management network on the host.

Version-Release number of selected component (if applicable):
Fedora 19, ovirt-engine 3.3 nightly - git0c5620a, adding to 3.3 cluster

host deploy exits with success.

I'll attach ifcfg* to the bug.
Comment 1 Sandro Bonazzola 2013-07-24 05:15:14 EDT
Created attachment 777681 [details]
ifcfg-em1 before adding the host
Comment 2 Sandro Bonazzola 2013-07-24 05:16:02 EDT
Created attachment 777682 [details]
ifcfg-em1 after adding the host
Comment 3 Sandro Bonazzola 2013-07-24 05:16:54 EDT
Created attachment 777683 [details]
ifcfg-ovirtmgmt created after adding the host
Comment 4 Dan Kenigsberg 2013-07-31 11:09:59 EDT
from the original ifcfg-em1:
======================
IPADDR0=192.168.1.107
PREFIX0=24
GATEWAY0=192.168.1.1

Are these trailing 0s conventional? Is it a new anaconda behavior?

I suspect that vdsm does not parse them, and not expose them properly to Engine. Vdsm should better treat them as their zero-less form (just as initscripts does?)
Comment 5 Sandro Bonazzola 2013-08-01 02:10:09 EDT
(In reply to Dan Kenigsberg from comment #4)

> Are these trailing 0s conventional? Is it a new anaconda behavior?

Not sure if the trailing 0s are from anaconda or from gnome network configuration app. However they come from system configuration tools so we can expect to find them quite often.
Comment 7 Dan Kenigsberg 2013-09-21 11:44:34 EDT
In a (late) second thought, I think that it would be much nicer to solve this on the Engine side. Engine should avoid relying on the 'cfg' parameter of network devices, as 'cfg' utterly breaks the Vdsm abstraction and does not fit into where Vdsm wants to go (non-ifcfg netconf).

IPADDR and GATEWAY should be take from the network's 'addr' and 'gateway' attributes. If I am not mistaken at the moment, the only need for 'cfg' is BOOTPROTO and BONDING_OPTS. Can we make everything else go?
Comment 8 Moti Asayag 2013-09-22 04:05:08 EDT
(In reply to Dan Kenigsberg from comment #7)
> In a (late) second thought, I think that it would be much nicer to solve
> this on the Engine side. Engine should avoid relying on the 'cfg' parameter
> of network devices, as 'cfg' utterly breaks the Vdsm abstraction and does
> not fit into where Vdsm wants to go (non-ifcfg netconf).
> 
> IPADDR and GATEWAY should be take from the network's 'addr' and 'gateway'
> attributes. If I am not mistaken at the moment, the only need for 'cfg' is
> BOOTPROTO and BONDING_OPTS. Can we make everything else go?

When you're adding a new host, there are no records on it for in the 'networks' element. Therefore we should rely on some other attribute which could provide the engine the ip address and the gateway of the specific interface.

Perhaps we'd like to extend the api of the last_client_iface to provide these values so they won't be tied to a specific implementation.
Comment 9 Dan Kenigsberg 2013-09-22 04:55:35 EDT
Oh. 'addr' is already reported per device, however 'gateway' is only a network property. Vdsm would have to report 'gateway' and 'bootproto' per device in order for Engine to drop the 'cfg' dependency.
Comment 11 Sven Kieske 2014-01-13 02:59:58 EST
Does this also affect EL 6 based Hosts?
Does this just affect the minimal node iso or also the "full blown host" install?
Comment 12 Dan Kenigsberg 2014-01-16 08:59:06 EST
http://gerrit.ovirt.org/23329/ does not add a new 'gateway' attribute. It only translates GATEWAY0 to GATEWAY, and keeps the ifcfg dependency.
Comment 13 Sandro Bonazzola 2014-01-27 08:45:13 EST
This should be fixed in 3.4.0 beta1
Comment 14 Martin Pavlik 2014-02-17 09:14:47 EST
verified
 oVirt Engine Version: 3.4.0-0.7.beta2.el6
Comment 15 Sandro Bonazzola 2014-03-31 08:32:00 EDT
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released

Note You need to log in before you can comment on or make changes to this bug.