Bug 987833 - dumpStorageTable produces an avoidable traceback if vdsmd is down.
dumpStorageTable produces an avoidable traceback if vdsmd is down.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.2.0
All Linux
low Severity low
: ---
: 3.3.0
Assigned To: Lee Yarwood
Aharon Canan
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 05:14 EDT by Lee Yarwood
Modified: 2016-02-10 13:34 EST (History)
9 users (show)

See Also:
Fixed In Version: v4.12.0
Doc Type: Bug Fix
Doc Text:
When vdsmd was down the first getConnectedStoragePoolsList call resulted in a 'Connection Refused' trace being shown. To avoid this trace being picked up by the automatic bug reporting tool, the connection is now tested first, catching any errors before continuing.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:29:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17278 None None None Never
Red Hat Product Errata RHBA-2014:0040 normal SHIPPED_LIVE vdsm bug fix and enhancement update 2014-01-21 15:26:21 EST

  None (edit)
Description Lee Yarwood 2013-07-24 05:14:32 EDT
Description of problem:

dumpStorageTable produces an avoidable traceback if vdsmd is down. This is in turn picked up by abrt and can worry users.

# service vdsmd stop
Shutting down vdsm daemon: 
vdsm watchdog stop                                         [  OK  ]
vdsm stop                                                  [  OK  ]
# python /usr/share/vdsm/dumpStorageTable.py
Traceback (most recent call last):
  File "/usr/share/vdsm/dumpStorageTable.py", line 307, in <module>
    rc, msg = StorageTable(vdscli.connect()).show()
  File "/usr/share/vdsm/dumpStorageTable.py", line 34, in __init__
    self._buildStorageTable()
  File "/usr/share/vdsm/dumpStorageTable.py", line 164, in _buildStorageTable
    pools = self.serverConncetion.getConnectedStoragePoolsList()
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1235, in request
    self.send_content(h, request_body)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1349, in send_content
    connection.endheaders()
  File "/usr/lib64/python2.6/httplib.py", line 908, in endheaders
    self._send_output()
  File "/usr/lib64/python2.6/httplib.py", line 780, in _send_output
    self.send(msg)
  File "/usr/lib64/python2.6/httplib.py", line 739, in send
    self.connect()
  File "/usr/lib64/python2.6/site-packages/vdsm/SecureXMLRPCServer.py", line 165, in connect
    sock = socket.create_connection((self.host, self.port), self.timeout)
  File "/usr/lib64/python2.6/socket.py", line 567, in create_connection
    raise error, msg
socket.error: [Errno 111] Connection refused

Version-Release number of selected component (if applicable):
vdsm-4.10.2-23.0.el6ev.x86_64


How reproducible:
Always.

Steps to Reproduce:
1. Stop vdsmd.
2. Run dumpStorageTable.py.
3.

Actual results:
Connection refused traceback displayed and captured by abrt.

Expected results:
No traceback displayed or captured by abrt.

Additional info:
Comment 4 Aharon Canan 2013-08-15 08:27:12 EDT
verified using is10 according to above steps

[root@camel-vdsb ~]# /etc/init.d/vdsmd stop
Shutting down vdsm daemon: 
vdsm watchdog stop                                         [  OK  ]
vdsm stop                                                  [  OK  ]
[root@camel-vdsb ~]# python /usr/share/vdsm/dumpStorageTable.py
Unable to connect to vdsmd [Errno 111] Connection refused
Comment 5 Charlie 2013-11-27 19:26:30 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 6 errata-xmlrpc 2014-01-21 11:29:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.