Bug 987883 - context menu: the "New" context-menu-item is irrelevant when there are selected row(s) in the grid.
context menu: the "New" context-menu-item is irrelevant when there are select...
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
ux
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 07:11 EDT by Alissa
Modified: 2013-08-19 06:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-12 17:57:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alissa 2013-07-24 07:11:29 EDT
Description of problem:
webadmin UI --> virtual machines tab.
Stand on a vm, right click - a context menu opens.
It contains "new VM" option, however this option irrelevant for the context - a vm is selected and the options in the menu should be related to the vm (edit/pause, etc.)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Michal Skrivanek 2013-07-25 10:10:30 EDT
this is actually intentional and the same as in 3.2. The menu is always complete. I agree it probably doesn't make much sense...on the other the menu is the same as teh horizontal one and taking out just this single item may cause a confusion as well
Comment 2 Einav Cohen 2013-07-25 12:37:38 EDT
[marking as 'ux' as this issue exists across the entire system (pretty much in any tab/sub-tab with a "New" button)]

[changing the subject accordingly]

[re-opening for now]

I agree with Michal - disabling the "New" item in the context menu while keeping the "New" button on the top panel enabled makes some sense, but creates an inconsistency between the context-menu and the buttons-top-panel, which may cause a confusion.

I assume that we can consider *removing* the "New" context-menu item when something is selected in the grid; although will also create some inconsistency, I think it will be less confusing; moreover, we already have items that are available only from the context-menu and not from the buttons-top-panel (e.g. "console options" in "VMs" main tab, "Re-initialize Data-Center" in "Data Centers" main tab), so there are already some inconsistencies in that sense.

@Malini/Eldan - any thoughts on this matter?
Comment 3 mrao 2013-08-12 16:47:11 EDT
(In reply to Einav Cohen from comment #2)
> [marking as 'ux' as this issue exists across the entire system (pretty much
> in any tab/sub-tab with a "New" button)]
> 
> [changing the subject accordingly]
> 
> [re-opening for now]
> 
> I agree with Michal - disabling the "New" item in the context menu while
> keeping the "New" button on the top panel enabled makes some sense, but
> creates an inconsistency between the context-menu and the buttons-top-panel,
> which may cause a confusion.
> 
> I assume that we can consider *removing* the "New" context-menu item when
> something is selected in the grid; although will also create some
> inconsistency, I think it will be less confusing; moreover, we already have
> items that are available only from the context-menu and not from the
> buttons-top-panel (e.g. "console options" in "VMs" main tab, "Re-initialize
> Data-Center" in "Data Centers" main tab), so there are already some
> inconsistencies in that sense.
> 
> @Malini/Eldan - any thoughts on this matter?

I think it is not a big deal to make the options on the top be inconsistent from the options in the context menu only because the options on the context menu apply to the selected row context while the options on the top are list specific (i.e option to add to the list or manage/ act on one or more rows in the list). So strictly speaking, 'New' should be removed from the context menu and we'll be all set.

Having said that, it is not uncommon to have the new option on the context menu as well and this is mostly for convenience - so that the user doesn't always have to go/scroll up to the top to create a new entity. So, I would be ok to leave it as is. No other option that is not context relevant should be added to the context menu for any notion of 'completeness'. 'New' is the only "acceptable" exception to the list.
Comment 4 Einav Cohen 2013-08-12 17:57:50 EDT
thanks for your take on this, Malini. 
Based on your answer, I am closing this bug.
Comment 5 Eldan Hildesheim 2013-08-19 06:29:07 EDT
Agree with Malini

Note You need to log in before you can comment on or make changes to this bug.