Bug 987888 - Openstack-packstack: packstack install Nova compute service [y|n] [y] : n - Raises SequenceError: 'CONFIG_QPID_HOST'.
Openstack-packstack: packstack install Nova compute service [y|n] [y] : n -...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: rc
: 4.0
Assigned To: Ivan Chavero
Udi
:
Depends On:
Blocks: RHEV_Neutron_Appliance
  Show dependency treegraph
 
Reported: 2013-07-24 07:27 EDT by Omri Hochman
Modified: 2014-03-20 08:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:15:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
setup.log (5.97 KB, text/x-log)
2013-07-24 07:31 EDT, Omri Hochman
no flags Details
answer-file.log (9.76 KB, text/plain)
2013-07-24 07:31 EDT, Omri Hochman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 52266 None None None Never

  None (edit)
Description Omri Hochman 2013-07-24 07:27:03 EDT
Openstack-packstack: packstack install Nova compute service [y|n]  [y] : n  - Raises SequenceError: 'CONFIG_QPID_HOST'.


Description:
------------
I wanted to install environment that will have all openstack services, beside 'openstack-nova-compute' - for testing Cells . 

from :
-------
http://docs.openstack.org/trunk/openstack-compute/admin/content/ch_cells.html

" Cells are configured as a tree. The top-level cell should have a host that runs a nova-api service, but no nova-compute services. Each child cell should run all of the typical nova-* services in a regular Compute cloud except for nova-api"


In order to do so I choose:
packstack install Nova compute service [y|n]  [y] : n

From the answer file (attached):
---------------------
# Set to 'y' if you would like Packstack to install Nova
CONFIG_NOVA_INSTALL=n

# The IP address of the server on which to install the QPID service
CONFIG_QPID_HOST=10.35.160.141


Results : 
---------
installation failed with SequenceError: 'CONFIG_QPID_HOST'. although from looking at the answer-file the qpid host = <LocalHost IP>  

setup.log
---------
2013-07-24 13:53:00::INFO::run_setup::505::root:: keystone-host: 10.35.160.141
2013-07-24 13:53:00::INFO::run_setup::505::root:: glance-host: 10.35.160.141
2013-07-24 13:53:00::INFO::run_setup::505::root:: cinder-host: 10.35.160.141
2013-07-24 13:53:00::INFO::run_setup::505::root:: cinder-volumes-create: y
2013-07-24 13:53:00::INFO::run_setup::505::root:: cinder-volumes-size: 20G
2013-07-24 13:53:00::INFO::run_setup::505::root:: osclient-host: 10.35.160.141
2013-07-24 13:53:00::INFO::run_setup::505::root:: os-horizon-host: 10.35.160.141
2013-07-24 13:53:00::INFO::run_setup::505::root:: os-horizon-ssl: n
2013-07-24 13:53:00::INFO::run_setup::505::root:: use-epel: n
2013-07-24 13:53:00::INFO::run_setup::505::root:: additional-repo: 
2013-07-24 13:53:00::INFO::run_setup::505::root:: rh-username: 
2013-07-24 13:53:00::INFO::run_setup::501::root:: rh-password: 
2013-07-24 13:53:00::INFO::run_setup::505::root:: rh-beta-repo: n
2013-07-24 13:53:00::INFO::run_setup::505::root:: rhn-satellite-server: 
2013-07-24 13:53:00::INFO::run_setup::507::root:: *** User input summary ***
2013-07-24 13:57:48::ERROR::run_setup::889::root:: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 884, in main
    _main(confFile)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 577, in _main
    runSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 554, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/setup_controller.py", line 90, in runAllSequences
    sequence.run(self.CONF)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 105, in run
    step.run(config=config)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 52, in run
    raise SequenceError(str(ex))
SequenceError: 'CONFIG_QPID_HOST'

2013-07-24 13:57:48::INFO::run_setup::532::root::  * A new answerfile was created in: /root/packstack-answers-20130724-135300.txt
2013-07-24 13:57:48::INFO::run_setup::532::root::  * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
2013-07-24 13:57:48::INFO::run_setup::532::root::  * Did not create a cinder volume group, one already existed
(END)
Comment 1 Omri Hochman 2013-07-24 07:31:03 EDT
Created attachment 777739 [details]
setup.log
Comment 2 Omri Hochman 2013-07-24 07:31:36 EDT
Created attachment 777740 [details]
answer-file.log
Comment 5 Alvaro Lopez Ortega 2013-12-05 09:53:44 EST
https://review.openstack.org/#/c/52266/ has been merged
Comment 8 Udi 2013-12-18 09:09:37 EST
Works with no problems in: openstack-packstack-2013.2.1-0.20.dev936.el6ost.noarch
Comment 10 errata-xmlrpc 2013-12-19 19:15:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.