Bug 987915 - Missing correlation-Id for adding new host
Missing correlation-Id for adding new host
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: m1
: 3.3.2
Assigned To: Mooli Tayer
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 08:12 EDT by Moti Asayag
Modified: 2013-12-19 09:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 09:24:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (523.34 KB, text/x-log)
2013-07-24 08:12 EDT, Moti Asayag
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20160 None None None Never
oVirt gerrit 20325 None None None Never

  None (edit)
Description Moti Asayag 2013-07-24 08:12:31 EDT
Created attachment 777758 [details]
engine.log

Description of problem:
A correlation id isn't created for 'Add Host' action.
Without the correlation-id, it is less convenient to track the installation flow on the engine log and since setup network is used to configure the network on vdsm, that value doesn't pass to vdsm (although mostly relevant for first installation where the log file is relatively short at that point of time) 
Version-Release number of selected component (if applicable):

How reproducible:
always

Steps to Reproduce:
1. Add host via the UI
2. Open engine log and track 'AddVdsCommand'

Actual results:
No correlation id for the command, although invoked by an external user.
2013-07-24 09:57:26,728 INFO  [org.ovirt.engine.core.bll.AddVdsCommand] (ajp--
127.0.0.1-8702-10) Running command: AddVdsCommand internal: false. Entities affected :  ID: 99408929-82cf-4dc7-a532-9d998063fa95 Type: VdsGroups

Expected results:
2013-07-24 09:57:26,728 INFO  [org.ovirt.engine.core.bll.AddVdsCommand] (ajp--
127.0.0.1-8702-10) Running command: AddVdsCommand internal: false. Entities affected :  ID: 99408929-82cf-4dc7-a532-9d998063fa95 Type: VdsGroups


Additional info:
The RemoveVdsCommand which also invoked by the user does contain the correlation id. However the RemoveVdsCommand called by the UI is invoked as a MultipleAction, therefore its threads are created from the engine thread-pool-util (pool-6-thread-50) which the AddVdsCommand allocated thread is taken from other thread pool (ajp--127.0.0.1-8702).

2013-07-24 09:53:47,398 INFO  [org.ovirt.engine.core.bll.RemoveVdsCommand] (pool-6-thread-50) [63a05356] Lock freed to object EngineLock [exclusiveLocks= key: a32d0adf-8f13-4f98-9d06-594c62859827 value: VDS
, sharedLocks= ]
2013-07-24 09:57:26,728 INFO  [org.ovirt.engine.core.bll.AddVdsCommand] (ajp--127.0.0.1-8702-10) Running command: AddVdsCommand internal: false. Entities affected :  ID: 99408929-82cf-4dc7-a532-9d998063fa95 Type: VdsGroups
Comment 1 Mooli Tayer 2013-10-14 08:48:25 EDT
A bug was introduces in http://gerrit.ovirt.org/#/c/15795/16 causing all commands 1.) not executed by MultipleActionRunner 
AND
2.) not provided with correlationId in initial parameters
to not print a correlationId to the log. 

proposing patch upstream.
Comment 2 Mooli Tayer 2013-10-20 07:42:21 EDT
Submitted under ovirt-engine-3.3
Comment 3 Sandro Bonazzola 2013-12-13 11:01:52 EST
rc build done, moving to ON_QA, packages will be available on updates-testing repository.
Comment 4 Sandro Bonazzola 2013-12-19 09:24:16 EST
oVirt 3.3.2 has been released resolving the problem described in this bug report.

Note You need to log in before you can comment on or make changes to this bug.