Bug 987916 - [oVirt] [provider] Dialog doesn't update unless focus lost
[oVirt] [provider] Dialog doesn't update unless focus lost
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.3
Unspecified Unspecified
medium Severity medium
: ---
: 3.5.0
Assigned To: Lior Vernia
GenadiC
network
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 08:12 EDT by Mike Kolesnik
Modified: 2016-02-10 14:36 EST (History)
11 users (show)

See Also:
Fixed In Version: ovirt-engine-3.5.0_beta
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-17 08:26:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21719 None None None Never
oVirt gerrit 26845 master MERGED webadmin: Swap KEYPRESS for KEYDOWN in ListModelListBox Never

  None (edit)
Description Mike Kolesnik 2013-07-24 08:12:38 EDT
Description of problem:
The "Add Provider" dialog doesn't update when changing the provider type, unless focus is lost.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Go to External Providers
2. Click the Add button
3. Use tab to get to the type field
4. Switch type of provider
  
Actual results:
Dialog stays the same


Expected results:
Dialog should change according to the type


Additional info:
Perhaps not on change, but there probably should be other way to trigger the dialog change other than losing focus on the field.

Enter/ESC fields will close the dialog with OK/Cancel action (respectively)
Comment 1 Sandro Bonazzola 2013-11-28 10:34:19 EST
Re-targeting to 3.3.3 since the bug is not resolved in 3.3.2 beta and is not blocking 3.3.2 release tracker (bug #1027349)
Comment 2 Sandro Bonazzola 2014-01-13 08:57:11 EST
oVirt 3.4.0 alpha has been released including the fix for this issue.
Comment 3 GenadiC 2014-02-18 04:54:35 EST
Failed for Firefox 27
Comment 4 Lior Vernia 2014-02-18 07:28:15 EST
Interesting, works for me on Firefox 22, but also found that it fails on Firefox 26.
Comment 5 Sandro Bonazzola 2014-03-04 04:23:44 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.
Comment 6 Lior Vernia 2014-03-19 11:48:19 EDT
Assigning to Alona who's become somewhat of an expert of Firefox quirks :) This looks like another KEY_PRESS/KEY_DOWN issue.
Comment 7 Sandro Bonazzola 2014-05-08 09:56:43 EDT
This is an automated message.

oVirt 3.4.1 has been released.
This issue has been retargeted to 3.5.0 since it has not been marked as high priority or severity issue, please retarget if needed.
Comment 8 GenadiC 2014-07-02 07:55:41 EDT
Verified in 3.5.0-0.0.master.20140629172257.git0b16ed7.el6
Comment 9 Sandro Bonazzola 2014-10-17 08:26:38 EDT
oVirt 3.5 has been released and should include the fix for this issue.

Note You need to log in before you can comment on or make changes to this bug.