Bug 987921 - Upgrading a RHEL host from VDSM 3.2 to 3.3 does not disable ksmtuned, but MOM makes calls to ksm as well
Upgrading a RHEL host from VDSM 3.2 to 3.3 does not disable ksmtuned, but MOM...
Status: CLOSED DUPLICATE of bug 987926
Product: oVirt
Classification: Community
Component: mom (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Litke
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 08:20 EDT by Assaf Muller
Modified: 2013-07-24 08:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 08:23:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Assaf Muller 2013-07-24 08:20:09 EDT
Description of problem:
In 3.2 VDSM talked to ksm via ksmtuned. 3.3 VDSM uses MOM to talk to ksm, but upgrading VDSM from 3.2 to 3.3 doesn't disable ksmtuned. That means that VDSM may send conflicting instructions to KSM as both ksmtuned and MOM are active. In systemd we marked VDSM as conflicting with ksmtuned, so something similar needs to happen with systemV.

Additionally, there is a nontrivial amount of code in VDSM with the 

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.3.0-0.3.beta1.fc19
VDSM 4.12.0-0.1.rc3
Comment 1 Assaf Muller 2013-07-24 08:23:46 EDT

*** This bug has been marked as a duplicate of bug 987926 ***

Note You need to log in before you can comment on or make changes to this bug.