Bug 987932 - copy operation does not exit if the operation gets postponed.
copy operation does not exit if the operation gets postponed.
Status: CLOSED NOTABUG
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.2 Beta
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.2.0
Assigned To: Michael Hrivnak
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 08:34 EDT by Preethi Thomas
Modified: 2013-09-09 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-30 11:28:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2013-07-24 08:34:55 EDT
Description of problem:

You will need to ctrl+c out if the copy operation gets postponed due to another  copy operation running

Version-Release number of selected component (if applicable):

[root@mgmt12 ~]# rpm -qa pulp-server
pulp-server-2.2.0-0.21.beta.el6.noarch
[root@mgmt12 ~]# 

How reproducible:


Steps to Reproduce:
1. Run a repo copy
2. Run a second repo copy while the first one is running
3.

Actual results:
root@mgmt12 ~]# pulp-admin rpm repo copy group  -f rhel64-x86 -t rhel64-copy
This command may be exited via ctrl+c without affecting the request.

[-]
The request was accepted but postponed due to one or more previous requests
against the resource. This request will proceed at the earliest possible time.




Expected results:


Additional info:
Comment 1 Michael Hrivnak 2013-07-30 11:28:26 EDT
This seems to be the expected behavior. The command will continue to poll the task's state, and when the task eventually does start to run, the normal progress report and other output will be displayed.

We can talk about whether there is some way to improve this experience, but for now, I think this is not actually a bug.

Note You need to log in before you can comment on or make changes to this bug.