Bug 987950 - Can't add node to ovirt-engine-3.3
Can't add node to ovirt-engine-3.3
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.3
All Linux
unspecified Severity urgent
: ---
: 3.3
Assigned To: Mike Burns
node
:
Depends On: 989003
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 08:59 EDT by Sandro Bonazzola
Modified: 2013-11-27 04:56 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 04:56:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Bonazzola 2013-07-24 08:59:57 EDT
Description of problem:
Trying to setup an hypervisor using ovirt-node on ovirt-engine 3.3 during test day.

http://resources.ovirt.org/releases/node-base/nightly/iso/ovirt-node-iso-3.0.0-5.0.1.fc19.iso can't be used because it doesn't have vdsm

http://resources.ovirt.org/releases/stable/iso/ovirt-node-iso-2.6.1-20120228.fc18.iso has vdsm but when I try to add the node to the engine the host doesn't show up in any datacenter.

Using oVirt Engine menu on hypervisor, set up connection parameters and password, on hypervisor I see:
 Setting Engine password
 Activating VDSM
 All changes were applied successfully.
 The host is not listed in any datacenter on engine.

Going to the UI selected a datacenter with 3.2 compatibility, the UI doesn't allow to change username to 'engine', is hardcoded to 'root' and setting the same password specified on the hypervisor doesn't work, says access denied


Version-Release number of selected component (if applicable):
Fedora 19, nightly - git0c5620a, 2 datacenter each one with one cluster. The first is 3.3 compatible, the second is 3.2 compatible
Comment 1 Mike Burns 2013-07-25 10:46:21 EDT
It's possible that there was an issue with setting the password in the 2.6.1 version.  

@dougsland -- do you recall if this was true or not?

FWIW, I'm not inclined to fix this in 2.6.x, but we should ensure that this gets fixed in 3.0.0
Comment 2 Douglas Schilling Landgraf 2013-07-26 22:49:29 EDT
(In reply to Mike Burns from comment #1)
> It's possible that there was an issue with setting the password in the 2.6.1
> version.  
> 
> @dougsland -- do you recall if this was true or not?

true, just checked.

> 
> FWIW, I'm not inclined to fix this in 2.6.x, but we should ensure that this
> gets fixed in 3.0.0

Agreed. Opened https://bugzilla.redhat.com/show_bug.cgi?id=989003 for the specific password stuff.
Comment 3 Joey Boggs 2013-08-06 16:20:05 EDT
fixed in bz989003
Comment 4 Sandro Bonazzola 2013-11-27 04:56:46 EST
A new node iso has been released with oVirt 3.3.1, closing.

Note You need to log in before you can comment on or make changes to this bug.