Bug 987961 - Executable files in qpid-cpp-win package cannot run due missing dependencies
Executable files in qpid-cpp-win package cannot run due missing dependencies
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-sdk (Show other bugs)
Development
Unspecified Windows
high Severity high
: 3.0
: ---
Assigned To: Chuck Rolke
Petra Svobodová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 09:20 EDT by Petra Svobodová
Modified: 2015-01-21 07:57 EST (History)
3 users (show)

See Also:
Fixed In Version: qpid-cpp-win-3.22.16.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-21 07:57:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-5017 None None None Never
Apache JIRA QPID-5114 None None None Never

  None (edit)
Description Petra Svobodová 2013-07-24 09:20:24 EDT
Description of problem:
Executable files placed in "bin" directory: "qpid-ping.exe", "qpid-receive.exe", "qpid-send.exe", "qpid-topic-listener.exe", "qpid-topic-publisher.exe", "receiver.exe" and "sender.exe" cannot be started; one or more libraries could not be found.

Version-Release number of selected component (if applicable):
qpid-cpp-win-3.22.7.1-1

How reproducible:
100%

Steps to Reproduce:
1.Download and unpack qpid-cpp-win packages.
2. Try to start one of applications in ~/bin directory (f.e. qpid-send.exe)


Actual results:
The application does not start and writes ae error message about missing dependencies.
In case qpid-send.exe application the error message is: "This application has failed to start because qpidmessaging.dll was not found. Re-installing the application may fix this problem."

Expected results:
The application should run without error messages.
Comment 1 Chuck Rolke 2013-07-25 14:03:03 EDT
From QPID-5017:

Several new[1] files have been added to C++ install

    qmf-gen
    qpidt
    qpid-ping
    qpid-send
    qpid-receive
    qpid-topic-listener
    qpid-topic-publisher
    sender
    receiver

But these files are not properly disposed in the WinSDK build process. WinSDK separates the debug and release variants into separate subdirectories bin\Debug and bin\Release. The files listed above are installed twice to \bin with the Release variants overwriting the Debug variants. The final SDK is left with only the Release variants sitting in the wrong directory.

These files should be moved into bin\Debug after the debug build and moved again into bin\Release after the release build.

[1] 2012-10-22
Comment 2 Chuck Rolke 2013-07-31 16:58:35 EDT
Upon further reflection a better strategy for these files is to simply delete them during the creation of the SDK. WinSDK is a vehicle for delivering qpid client libraries and not for delivering generally useful tools. A general tool kit needs much more than these few files and is beyond the scope of WinSDK.

Patch upstream at r1509016.
Comment 3 Petra Svobodová 2013-08-26 03:58:43 EDT
Due to planning remove "qpid-perftest" application (see https://bugzilla.redhat.com/show_bug.cgi?id=789412), it is needed to keep at least "qpid-send" and "qpid-receive" applications in the Windows kit to be able to measure performance of the Windows client by "qpid-benchmark" tool. 

Could you possibly compile and add at least these two applications "qpid-send" and "qpid-receive" back into the Windows package, please?

--> ASSIGNED
Comment 5 Chuck Rolke 2013-09-05 16:44:26 EDT
Committed upstream at r1520417
Adds bin\Release\qpid-send.exe and bin\Release\qpid-receive.exe
to the WinSDK
Comment 8 Petra Svobodová 2013-09-24 11:34:42 EDT
All executable files contained in the "bin" directory, "qpid-perftest.exe", "qpid-latency-test.exe", "qpid-send.exe", "qpid-receive.exe", "qpid-txtest.exe", "qpid-client-test.exe" are able to run on all currently supported Windows platforms.

Verified on packages qpid-cpp-win-3.22.16.1-1, on WindowsXP-x86, Windows7-x86 and x64, Windows Server2003-x86 and x64, Windows2008-x86, x64 and R2.

--> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.