Bug 987965 - Cannot run vm with spice console protocol
Cannot run vm with spice console protocol
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
3.2
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.3
Assigned To: Saveliev Peter
Haim
virt
:
Depends On:
Blocks: 918494
  Show dependency treegraph
 
Reported: 2013-07-24 09:30 EDT by Alona Kaplan
Modified: 2014-01-12 19:57 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 10:51:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm log (198.79 KB, text/x-log)
2013-07-24 09:30 EDT, Alona Kaplan
no flags Details
engine log (335.22 KB, text/x-log)
2013-07-24 09:32 EDT, Alona Kaplan
no flags Details
libvirt log (8.68 MB, text/x-log)
2013-08-01 06:46 EDT, Alona Kaplan
no flags Details

  None (edit)
Description Alona Kaplan 2013-07-24 09:30:20 EDT
Created attachment 777791 [details]
vdsm log

Description of problem:
Cannot run vm with spice console protocol.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Add a vm
2. Change it console protocol to "spice"
3. Try to the the vm

Actual results:
Cannot run the vm. Exits with error- "internal error ifname "vnet6" not in key map."


Expected results:
The vm is up.

Additional info:
Comment 1 Alona Kaplan 2013-07-24 09:32:01 EDT
Created attachment 777792 [details]
engine log
Comment 2 Dan Kenigsberg 2013-07-24 10:28:07 EDT
Note the noisy line which seems related more to storage than to spice:

Thread-3287::WARNING::2013-07-24 16:24:34,414::clientIF::337::vds::(teardownVolumePath) Drive is not a vdsm image: VOLWM_CHUNK_MB:1024 VOLWM_CHUNK_REPLICATE_MULT:2 VOLWM_FREE_PCT:50 _blockDev:False _checkIoTuneCategories:<bound method Drive._checkIoTuneCategories of <vm.Drive object at 0x153d990>> _customize:<bound method ... {'path': ''} truesize:0 type:disk volExtensionChunk:1024 watermarkLimit:536870912
Traceback (most recent call last):
  File "/usr/share/vdsm/clientIF.py", line 331, in teardownVolumePath
    res = self.irs.teardownImage(drive['domainID'],
  File "/usr/share/vdsm/vm.py", line 1342, in __getitem__
    raise KeyError(key)
KeyError: 'domainID'
Comment 3 Saveliev Peter 2013-07-31 11:20:17 EDT
Alona, can you pls provide also libvirtd log for the case?
Comment 4 Alona Kaplan 2013-08-01 06:46:18 EDT
Created attachment 781524 [details]
libvirt log
Comment 5 Michal Skrivanek 2013-08-02 09:56:15 EDT
the real culprit when starting the VM is:
2013-08-01 09:53:04.435+0000: 25244: error : qemuBuildCommandLine:6192 : unsupported configuration: spice secure channels set in XML configuration, but TLS is disabled in qemu.conf

However the supplied libvirt.log is not from the same time period as vdsm.log.
Alona, can you please confirm some modification re SSL setings?
Comment 6 Michal Skrivanek 2013-08-02 09:59:06 EDT
this daoesn't seem to be related to storage (nor networking, despite the numerous nw related errors in libvirt.log) - changing to "virt"

once Alona confirms this can be closed worksforme
Comment 7 Alona Kaplan 2013-08-05 09:30:43 EDT
I don't remember modifying any ssl setting.
My host is grey-vdsh.eng.lab.tlv.redhat.com you can check it.
Comment 8 Michal Skrivanek 2013-08-05 10:31:09 EDT
VM is created with

                <graphics autoport="yes" keymap="en-us" listen="0" passwd="*****" passwdValidTo="1970-01-01T00
:00:01" port="-1" tlsPort="-1" type="spice">
                        <channel mode="secure" name="main"/>
                        <channel mode="secure" name="inputs"/>
                        <channel mode="secure" name="cursor"/>
                        <channel mode="secure" name="playback"/>
                        <channel mode="secure" name="record"/>
                        <channel mode="secure" name="display"/>
                        <channel mode="secure" name="usbredir"/>
                        <channel mode="secure" name="smartcard"/>
                </graphics>

however TLS is disabled in config
Comment 9 Omer Frenkel 2013-08-05 10:51:02 EDT
> the real culprit when starting the VM is:
> 2013-08-01 09:53:04.435+0000: 25244: error : qemuBuildCommandLine:6192 :
> unsupported configuration: spice secure channels set in XML configuration,
> but TLS is disabled in qemu.conf
> 
> However the supplied libvirt.log is not from the same time period as
> vdsm.log.
> Alona, can you please confirm some modification re SSL setings?

we verified that indeed in engine config spice was configured to secure ("SSLEnabled") and in the host it was configured to non-secure, hence the configuration mismatch.
after changing in engine config to SSLEnabled=false we could start vms.

closing with not a bug as this was configuration error.

Note You need to log in before you can comment on or make changes to this bug.