Bug 987986 - [oVirt] [glance] NPE on disk export
[oVirt] [glance] NPE on disk export
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3
Assigned To: Ayal Baron
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 09:53 EDT by Mike Kolesnik
Modified: 2016-02-10 11:39 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 03:35:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17342 None None None Never

  None (edit)
Description Mike Kolesnik 2013-07-24 09:53:41 EDT
Description of problem:
Got NPE on export of disk to a glance storage domain


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Create a glance domain by creating a glance provider
2. Create a disk
3. try to export the disk to the glance domain
  
Actual results:
http://pastebin.test.redhat.com/154848


Expected results:
Should succeed


Additional info:
Tried with both preallocated/thin provisioned disks.
Disks had no snapshots.
Comment 1 Federico Simoncelli 2013-07-24 11:31:32 EDT
I've been able to reproduce this on master as well.
UI model is capable to set the correct parameters for the export, in particular the destinationStorageDomain uuid.

When the parameters are then received by the backend the destinationStorageDomain uuid is null.

I have the feeling that this has to do with serialization.
I'm going to look into this because it's mandatory to be fixed.
Comment 2 Federico Simoncelli 2013-07-26 11:42:26 EDT
As I believed this is a serialization issue. The workaround is to add an (apparently unused) default constructor for the export parameters.
Comment 3 Itamar Heim 2013-08-21 12:42:30 EDT
as RC is built, moving to ON_QA (hopefully did not catch incorrect bugs when doing this)
Comment 4 Itamar Heim 2013-09-23 03:35:27 EDT
closing as this should be in 3.3 (doing so in bulk, so may be incorrect)

Note You need to log in before you can comment on or make changes to this bug.