Bug 988044 - SELinux is preventing /usr/lib64/firefox/firefox (deleted) from using the 'ptrace' accesses on a process.
SELinux is preventing /usr/lib64/firefox/firefox (deleted) from using the 'pt...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:efbc4c3f0ae761744cd9431fdf7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 11:17 EDT by Casey Dahlin
Modified: 2014-06-18 04:47 EDT (History)
4 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-69.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-04 18:59:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Casey Dahlin 2013-07-24 11:17:41 EDT
Description of problem:
I'm not certain when this happened. It's backdated.

Given the relationship of the labels, I suspect the access was legitimate, but maybe this is something that should be fixed in firefox and not SELinux policy?
SELinux is preventing /usr/lib64/firefox/firefox (deleted) from using the 'ptrace' accesses on a process.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that firefox (deleted) should be allowed ptrace access on processes labeled mozilla_plugin_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep firefox /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                staff_u:staff_r:staff_t:s0-s0:c0.c1023
Target Context                staff_u:staff_r:mozilla_plugin_t:s0-s0:c0.c1023
Target Objects                 [ process ]
Source                        firefox
Source Path                   /usr/lib64/firefox/firefox (deleted)
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-96.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-06-17 15:37:17 EDT
Last Seen                     2013-06-17 15:37:17 EDT
Local ID                      656f3a69-6ed5-48ed-bc1a-a8773352d602

Raw Audit Messages
type=AVC msg=audit(1371497837.555:48941): avc:  denied  { ptrace } for  pid=2402 comm="firefox" scontext=staff_u:staff_r:staff_t:s0-s0:c0.c1023 tcontext=staff_u:staff_r:mozilla_plugin_t:s0-s0:c0.c1023 tclass=process


type=SYSCALL msg=audit(1371497837.555:48941): arch=x86_64 syscall=ptrace success=no exit=EACCES a0=10 a1=27cf a2=0 a3=0 items=0 ppid=2107 pid=2402 auid=11892 uid=11892 gid=11892 euid=11892 suid=11892 fsuid=11892 egid=11892 sgid=11892 fsgid=11892 ses=18 tty=(none) comm=firefox exe=2F7573722F6C696236342F66697265666F782F66697265666F78202864656C6574656429 subj=staff_u:staff_r:staff_t:s0-s0:c0.c1023 key=(null)

Hash: firefox,staff_t,mozilla_plugin_t,process,ptrace

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.8-300.fc19.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-07-24 17:36:07 EDT
Looks like firefox is trying to ptrace one  of its plugins, we should allow it unless the user turns on deny_ptrace.

671df206c6c85a6a222809e5bf7b5ab8242a2d80 fixes this in git.
Comment 2 Fedora Update System 2013-08-02 09:28:47 EDT
selinux-policy-3.12.1-69.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-69.fc19
Comment 3 Fedora Update System 2013-08-02 17:54:40 EDT
Package selinux-policy-3.12.1-69.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-69.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14089/selinux-policy-3.12.1-69.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-08-04 18:59:30 EDT
selinux-policy-3.12.1-69.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.