Bug 988070 - USB keyboard on POWER guests
USB keyboard on POWER guests
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
ppc64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks: 1122627
  Show dependency treegraph
 
Reported: 2013-07-24 12:36 EDT by Vitor de Lima
Modified: 2016-07-28 03:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1122627 (view as bug list)
Environment:
Last Closed: 2014-04-17 06:05:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A XML describing an emulated PPC64 pseries guest (598 bytes, text/xml)
2013-07-24 12:36 EDT, Vitor de Lima
no flags Details

  None (edit)
Description Vitor de Lima 2013-07-24 12:36:47 EDT
Created attachment 777861 [details]
A XML describing an emulated PPC64 pseries guest

Description of problem:
A simple description of a emulated PPC64 in a domain XML doesn't create a virtual keyboard.

Version-Release number of selected component (if applicable):
1.1.0

How reproducible:
100%

Steps to Reproduce:
1. Use virsh to create a domain based on the attached vm.xml file
2. Wait until the Open Firmware command prompt opens up
3. You cannot interact with the prompt since there is no virtual keyboard

Actual results:
It is not possible to write anything in the Open Firmware prompt.

Expected results:
There should be a way to interact with the Open Firmware prompt or create a virtual keyboard in the domain XML.

Additional info:
I haven't found a way to create a virtual USB keyboard through the libvirt, instead i used the "qemu:commandline" tag to pass the "-usbdevice keyboard" parameter to QEMU.
Comment 1 Ján Tomko 2014-04-17 06:05:44 EDT
This should be fixed upstream by:
commit 78730478aa3e3157b9d86b1054d32f61d6616880
Author:     Li Zhang <zhlcindy@linux.vnet.ibm.com>
CommitDate: 2014-02-19 09:16:31 +0100

    qemu: format qemu command line for USB keyboard
    
    Format qemu command line for USB keyboard
    and add test cases for it.
    
    Signed-off-by: Li Zhang <zhlcindy@linux.vnet.ibm.com>
    Signed-off-by: Ján Tomko <jtomko@redhat.com>

git describe: v1.2.1-244-g7873047 contains: v1.2.2-rc1~48

with the keyboard automatically added on PPC64:
commit cffa51b81d3ad166a7caf3d4ec08d88c41f273fe
Author:     Li Zhang <zhlcindy@linux.vnet.ibm.com>
AuthorDate: 2014-02-17 18:17:58 +0800
Commit:     Ján Tomko <jtomko@redhat.com>
CommitDate: 2014-02-19 09:16:31 +0100

    Add a default USB keyboard and USB mouse for PPC64
    
    There is no keyboard working on PPC64 and PS2 mouse is only for X86
    when graphics are enabled.
    
    Add a USB keyboard and USB mouse for PPC64 when graphics are enabled.
    
    Signed-off-by: Li Zhang <zhlcindy@linux.vnet.ibm.com>
    Signed-off-by: Ján Tomko <jtomko@redhat.com>

git describe: v1.2.1-246-gcffa51b contains: v1.2.2-rc1~46

Note You need to log in before you can comment on or make changes to this bug.