Bug 988112 - RFE: add +lua support
RFE: add +lua support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 14:33 EDT by Jeremey Hustman
Modified: 2016-04-11 07:28 EDT (History)
15 users (show)

See Also:
Fixed In Version: vim-7.4.417-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-22 21:53:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
karsten: needinfo-


Attachments (Terms of Use)
patch enabling Lua interpreter in spec (F19) (2.44 KB, patch)
2013-09-18 06:48 EDT, Jan Včelák
no flags Details | Diff

  None (edit)
Description Jeremey Hustman 2013-07-24 14:33:50 EDT
Description of problem:
Request +lua to be added in compilation.

Version-Release number of selected component (if applicable):
7.3+

How reproducible:
Not reproducible, feature addition request.

Steps to Reproduce:
1. yum search vim lua
2.
3.

Actual results:
No results

Expected results:
vim-lua.noarch : Lua implentation for VIM

Additional info:
Comment 1 Jeremey Hustman 2013-08-23 15:08:26 EDT
I've managed to workaround through the Fedora Forums:
http://forums.fedoraforum.org/showthread.php?t=292813
Comment 2 Jan Včelák 2013-09-18 06:44:08 EDT
I would love to see Lua support in Vim as well. There are some vim plugins which need it, e.g. neocomplete.

It adds just about 20kB to the binaries:

% du -bs *.extracted
2236072 vim-enhanced-7.4.027-2.fc19.x86_64.rpm.extracted
2257456 vim-enhanced-7.4.027-2.1.fc19.x86_64.rpm.extracted

Karsten, please, can you consider adding it?
Comment 3 Jan Včelák 2013-09-18 06:48:17 EDT
Created attachment 799316 [details]
patch enabling Lua interpreter in spec (F19)

Adding a patch to make Vim maintainer's life easier if this RFE is accepted.
Comment 4 Paulo Fidalgo 2013-12-30 05:04:58 EST
Watching the progress since the need of lua for neocomplete. Until this become official I need to compile my own VIM version.
Comment 5 Johnny Robeson 2014-02-11 21:26:42 EST
is there any issues with adding this feature Karsten?
Comment 7 kealthou 2014-02-28 05:45:30 EST
Can I ask you to turn on --with-luajit option?
Comment 8 virtualeyes 2014-07-08 08:28:02 EDT
+1 on the --with-luajit request.

Also, when will we be seeing a Lua enabled Vim in updates repo? July 8th today, have been on 179-1 for several months here with Fedora 20.

Thanks
Comment 9 Paulo Fidalgo 2014-07-28 11:47:40 EDT
Karsten, there is any chance for lua and luajit in the current stable f20?
Comment 10 Fedora Update System 2014-08-13 10:58:03 EDT
vim-7.4.402-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/vim-7.4.402-1.fc20
Comment 11 Fedora Update System 2014-08-13 10:58:27 EDT
vim-7.4.402-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/vim-7.4.402-1.fc19
Comment 12 Fedora Update System 2014-08-15 20:28:26 EDT
Package vim-7.4.402-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing vim-7.4.402-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9443/vim-7.4.402-1.fc20
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2014-08-22 21:53:50 EDT
vim-7.4.402-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2014-08-26 11:37:52 EDT
vim-7.4.417-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/vim-7.4.417-1.fc20
Comment 15 Fedora Update System 2014-08-26 11:38:15 EDT
vim-7.4.417-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/vim-7.4.417-1.fc19
Comment 16 Fedora Update System 2014-08-28 11:31:54 EDT
vim-7.4.417-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2014-09-19 06:05:39 EDT
vim-7.4.417-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Nicholas Kudriavtsev 2015-05-07 08:44:38 EDT
Why is lua disabled again in Fedora 22?
Comment 19 Parthkumar Bera 2015-06-11 09:51:59 EDT
Vim for Fedora 22 is not built with Lua support. Was it an intentional change? If not, could you please fix it through update channel?
Comment 20 Sebastian 2015-07-06 09:51:44 EDT
Would it be possible to add lua support again in the Fedora 22 build?
Comment 21 Luke Meyer 2015-07-19 07:42:10 EDT
Bug for vim and lua in Fedora 22 is https://bugzilla.redhat.com/show_bug.cgi?id=1203321

Note You need to log in before you can comment on or make changes to this bug.