Bug 988114 - Dependency check failed : (('mariadb-server', '1:5.5.31', '6.fc20'), ('systemd-units', '')
Dependency check failed : (('mariadb-server', '1:5.5.31', '6.fc20'), ('system...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mariadb (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 14:35 EDT by nucleo
Modified: 2013-07-29 01:45 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 01:45:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failed nigtly compose log (176.37 KB, text/plain)
2013-07-24 14:35 EDT, nucleo
no flags Details
yum debugging output installing mysql-server into a minimal buildroot (116.06 KB, text/plain)
2013-07-27 22:40 EDT, Dennis Gilmore
no flags Details

  None (edit)
Description nucleo 2013-07-24 14:35:10 EDT
Created attachment 777910 [details]
failed nigtly compose log

Description of problem:
F20 KDE live images nightly composes failed.


Version-Release number of selected component (if applicable):
livecd-tools-19.6-1.fc20

Actual results:
DEBUG util.py:264:  Error creating Live CD : Dependency check failed : (('mariadb-server', '1:5.5.31', '6.fc20'), ('systemd-units', ''), 0, 0, None)


Additional info:
mariadb-server requires systemd-units which provided by systemd, so should not be broken dependencies.
Comment 1 Brian Lane 2013-07-24 16:35:04 EDT
Failed deps are a transient repo problem, not a problem with livecd-tools.
Comment 2 nucleo 2013-07-24 16:41:28 EDT
Why you think that this is repo problem?
All KDE nightly composes failed because of this bug since F20 composes started, so Rawhide permanently broken?
Comment 3 nucleo 2013-07-24 16:53:19 EDT
mariadb-server installs fine in Rawhide without any problems with deps.
Comment 4 Brian Lane 2013-07-24 17:04:31 EDT
rawhide is frequently broken. This error comes from yum, and just reports the results of its dependency check using whatever repos were included in the kickstart.
Comment 5 nucleo 2013-07-24 17:11:25 EDT
Repo can be frequently broken but not all time with the same problem.
What yum in Rawhide saying:



# yum install akonadi-mysql
Loaded plugins: refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package akonadi-mysql.i686 0:1.10.0-1.fc20 will be installed
--> Processing Dependency: qt4-mysql(x86-32) for package: akonadi-mysql-1.10.0-1.fc20.i686
--> Processing Dependency: mysql-server for package: akonadi-mysql-1.10.0-1.fc20.i686
--> Running transaction check
---> Package mariadb-server.i686 1:5.5.31-6.fc20 will be installed
--> Processing Dependency: mariadb-libs(x86-32) = 1:5.5.31-6.fc20 for package: 1:mariadb-server-5.5.31-6.fc20.i686
--> Processing Dependency: mariadb(x86-32) = 1:5.5.31-6.fc20 for package: 1:mariadb-server-5.5.31-6.fc20.i686
--> Processing Dependency: perl-DBD-MySQL for package: 1:mariadb-server-5.5.31-6.fc20.i686
---> Package qt-mysql.i686 1:4.8.5-4.fc20 will be installed
--> Running transaction check
---> Package mariadb.i686 1:5.5.31-6.fc20 will be installed
---> Package mariadb-libs.i686 1:5.5.31-6.fc20 will be installed
---> Package perl-DBD-MySQL.i686 0:4.023-2.fc20 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================
 Package                     Arch              Version                       Repository            Size
========================================================================================================
Installing:
 akonadi-mysql               i686              1.10.0-1.fc20                 rawhide              6.7 k
Installing for dependencies:
 mariadb                     i686              1:5.5.31-6.fc20               rawhide              8.7 M
 mariadb-libs                i686              1:5.5.31-6.fc20               rawhide              740 k
 mariadb-server              i686              1:5.5.31-6.fc20               rawhide               10 M
 perl-DBD-MySQL              i686              4.023-2.fc20                  rawhide              139 k
 qt-mysql                    i686              1:4.8.5-4.fc20                rawhide               35 k

Transaction Summary
========================================================================================================
Install  1 Package (+5 Dependent packages)

Total download size: 20 M
Installed size: 103 M
Is this ok [y/d/N]: y
Downloading packages:
(1/6): akonadi-mysql-1.10.0-1.fc20.i686.rpm                                      | 6.7 kB  00:00:00     
(2/6): mariadb-libs-5.5.31-6.fc20.i686.rpm                                       | 740 kB  00:00:03     
(3/6): mariadb-5.5.31-6.fc20.i686.rpm                                            | 8.7 MB  00:00:11     
(4/6): perl-DBD-MySQL-4.023-2.fc20.i686.rpm                                      | 139 kB  00:00:02     
(5/6): qt-mysql-4.8.5-4.fc20.i686.rpm                                            |  35 kB  00:00:00     
(6/6): mariadb-server-5.5.31-6.fc20.i686.rpm                                     |  10 MB  00:00:14     
--------------------------------------------------------------------------------------------------------
Total                                                                   1.0 MB/s |  20 MB     00:19     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : 1:mariadb-libs-5.5.31-6.fc20.i686                                                    1/6 
  Installing : 1:mariadb-5.5.31-6.fc20.i686                                                         2/6 
  Installing : 1:qt-mysql-4.8.5-4.fc20.i686                                                         3/6 
  Installing : perl-DBD-MySQL-4.023-2.fc20.i686                                                     4/6 
  Installing : 1:mariadb-server-5.5.31-6.fc20.i686                                                  5/6 
  Installing : akonadi-mysql-1.10.0-1.fc20.i686                                                     6/6 
  Verifying  : 1:mariadb-server-5.5.31-6.fc20.i686                                                  1/6 
  Verifying  : akonadi-mysql-1.10.0-1.fc20.i686                                                     2/6 
  Verifying  : 1:mariadb-5.5.31-6.fc20.i686                                                         3/6 
  Verifying  : 1:qt-mysql-4.8.5-4.fc20.i686                                                         4/6 
  Verifying  : 1:mariadb-libs-5.5.31-6.fc20.i686                                                    5/6 
  Verifying  : perl-DBD-MySQL-4.023-2.fc20.i686                                                     6/6 

Installed:
  akonadi-mysql.i686 0:1.10.0-1.fc20                                                                    

Dependency Installed:
  mariadb.i686 1:5.5.31-6.fc20                        mariadb-libs.i686 1:5.5.31-6.fc20                 
  mariadb-server.i686 1:5.5.31-6.fc20                 perl-DBD-MySQL.i686 0:4.023-2.fc20                
  qt-mysql.i686 1:4.8.5-4.fc20                       

Complete!
Comment 6 nucleo 2013-07-24 17:14:41 EDT
No special repos added in KDE kickstart
https://git.fedorahosted.org/cgit/spin-kickstarts.git/plain/fedora-live-kde-base.ks
Comment 7 nucleo 2013-07-24 17:16:11 EDT
# repoquery --whatprovides systemd-units
systemd-0:206-1.fc20.i686
Comment 8 Bruno Wolff III 2013-07-24 17:21:58 EDT
mariadb should not be requiring systemd-units as it is deprcated and isn't in rawhide any more. You may have an old copy on your machine that allows you to install mariadb.
Comment 9 nucleo 2013-07-24 17:23:44 EDT
I uninstalled mariadb* with all deps before tunning 'yum install akonadi-mysql'.
Comment 10 Bruno Wolff III 2013-07-24 17:26:41 EDT
Well it does look like systemd claims to be providing this, but I expect this issue is somehow related to it being deprecated.
Comment 11 nucleo 2013-07-24 17:37:45 EDT
yum installed mariadb-5.5.31-6.fc20.

mariadb-5.5.32-2.fc20 which requires systemd built today for f20 tag (mariadb-5.5.31-7.fc20 tagged in f20-perl), so tomorrow problem will be fixed (or hidden).

Still unclear why if systemd-units provided by systemd, mariadb-server requires systemd-units and can be installed with yum but can't be installed by livecd-tools.
Comment 12 nucleo 2013-07-25 13:35:43 EDT
mariadb-5.5.32-2.fc20 now in Rawhide repo but nightly copose failed again:

DEBUG util.py:264:  Error creating Live CD : Dependency check failed : (('mariadb-server', '1:5.5.32', '2.fc20'), ('systemd', ''), 0, 0, None)

http://koji.fedoraproject.org/koji/taskinfo?taskID=5655959
Comment 13 Dennis Gilmore 2013-07-25 14:40:30 EDT
reassigning to yum.

DEBUG util.py:264:  ERROR with transaction check vs depsolve:
DEBUG util.py:264:  systemd is needed by mariadb-server-1:5.5.32-2.fc20.armv7hl

from a arm build of akonadi
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=2018250

systemd is on the transaction so something in yum/rpm is going very wrong.
Comment 14 Dennis Gilmore 2013-07-27 22:40:41 EDT
Created attachment 779256 [details]
yum debugging output installing mysql-server into a minimal buildroot
Comment 15 Dennis Gilmore 2013-07-29 01:45:43 EDT
fixed in mariadb-5.5.32-5 
- remove "Requires(pretrans): systemd" since its not possible
- when installing mariadb and systemd at the same time. as in a new install

the pretrans Requires makes it impossible to install systemd and mariadb-server in the same transaction so thr pretrans requires was removed

Note You need to log in before you can comment on or make changes to this bug.