Bug 988116 - [Big Bend EA] Volume capacity reported to Windows is incorrect
[Big Bend EA] Volume capacity reported to Windows is incorrect
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: Beta
: ---
Assigned To: Susant Kumar Palai
Sudhir D
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 14:39 EDT by jhoffer
Modified: 2013-09-23 18:29 EDT (History)
5 users (show)

See Also:
Fixed In Version: samba-3.6.9-159.1.el6rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:29:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jhoffer 2013-07-24 14:39:53 EDT
Description of problem:
When a gluster volume is mounted on a Windows client as a network drive letter, the capacity displayed by Windows is incorrect.  Each 1GB brick shows 4TB on Windows, 10GB bricks show 40TB.

Version-Release number of selected component (if applicable):
Windows7 client
glusterfs 3.4.0.12rhs.beta6 built on Jul 23 2013 16:20:03
RHS-2.1-20130724.n.0-RHS-x86_64-DVD1.iso

How reproducible:
Capacity is displayed by Windows Explorer 

Steps to Reproduce:
1. Create Gluster volume
2. Mount as network drive letter on Windows client (not just browse to share)
3. 
  
Actual results:
Network drive letter claims to be 40,000 times larger than it is.

Expected results:
Drive letter should report actual capacity.

Additional info:
Setting quota on volume does not seem to affect displayed capacity. Started with two 10GB bricks and saw ~80TB, added two more 10GB bricks and saw ~160TB.
Comment 3 Susant Kumar Palai 2013-08-07 05:12:34 EDT
Sent patch to samba upstream.

Link to mail thread containing the patch : https://lists.samba.org/archive/samba-technical/2013-August/094159.html

Upstream Bug id : https://bugzilla.samba.org/show_bug.cgi?id=10068
Comment 4 surabhi 2013-08-16 05:17:00 EDT
Verified with version :
samba-glusterfs-3.6.9-159.1.el6rhs.x86_64
glusterfs-3.4.0.19rhs-2.el6rhs.x86_64

After doing a mount of gluster volume on windows the volume capacity shown by windows is correct and is same as the actual capacity.

Tried with adding bricks and it shows the correct capacity in this case as well.
Comment 6 Scott Haines 2013-09-23 18:29:53 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.