Bug 988119 - Our API documentation uses Python specific names for data types, instead of JSON types
Our API documentation uses Python specific names for data types, instead of J...
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: documentation (Show other bugs)
Master
Unspecified Unspecified
low Severity low
: ---
: 2.3.0
Assigned To: Barnaby Court
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 14:54 EDT by Randy Barlow
Modified: 2013-12-09 09:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 09:30:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2013-07-24 14:54:42 EDT
I've noticed that we talk about "dictionaries" and "lists" in our documentation, which makes sense to us since we are a Python project. However, our API users might not always be working in a Python environment, and we are dealing in JSON across the wire, so it would be good for us to use JSON type names[0], such as object and array (instead of dictionary and list).

We should audit our API docs for these words and replace the usage of them so that our users will have an easier time understanding which data types we are referring to.

[0] http://en.wikipedia.org/wiki/JSON#Data_types.2C_syntax_and_example
Comment 1 Barnaby Court 2013-09-26 15:46:06 EDT
Pull Request: https://github.com/pulp/pulp/pull/637
Comment 2 Jeff Ortel 2013-09-26 16:54:18 EDT
build: 2.3.0-0.16.alpha
Comment 3 Preethi Thomas 2013-10-04 15:07:12 EDT
verified
Comment 4 Preethi Thomas 2013-12-09 09:30:55 EST
Pulp 2.3 released.

Note You need to log in before you can comment on or make changes to this bug.