Bug 98812 - Mouse throw and click to close
Mouse throw and click to close
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: redhat-artwork (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Garrett LeSage
David Lawrence
: FutureFeature, GraphicArt, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-08 22:39 EDT by Greg
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-07 06:03:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg 2003-07-08 22:39:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
When I have a window maximized and want to close the window, I would like to do
so by simply throwing the cursor to the top right-hand corner of the screen and
clicking. As it is, I have to aim for the "X" to close the window. Throwing my
mouse to the top right-hand corner only allows me to roll-up the window (and
only if I double-click), as is the case if I double-click anywhere on the title bar.

This is less of a problem on Ximian Gnome because the default setup includes a
top Gnome panel, which prevents the close button from being in the top
right-hand corner. However, Red Hat Gnome does not use the top Gnome panel by
default, meaning that the described functionality would be useful for Red Hat.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open any application and maximize it.
2. Throw mouse to the farthest top right-hand corner of the screen.
3. Click as if to close the application.
    

Actual Results:  Nothing. If I doubleclick, the window only rolls up.

Expected Results:  The window ought to close.

Additional info:
Comment 1 Havoc Pennington 2003-10-03 18:14:46 EDT
This is a theme thing afaik.
Comment 2 Alexander Larsson 2003-10-06 12:50:13 EDT
Yeah, this is the fitz-law complaint about the new metacity theme. Garrett, you
get do decide what to do about this.
Comment 3 Garrett LeSage 2003-10-06 14:56:23 EDT
There is no theme that allows for this, not even classic Bluecurve (although it
did appear to do so, it did not).

The clickable button size for the latest Bluecurve is just a pixel smaller in
each direction than the previous one -- the visible button size is two pixels
smaller, though -- but it is more apparent which button is which.
Comment 4 Alexander Larsson 2003-10-07 06:03:17 EDT
Then i'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.