Bug 9882 - "cvs release -d directory" aborts unconditionally
Summary: "cvs release -d directory" aborts unconditionally
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cvs   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-01 08:36 UTC by David Craig
Modified: 2007-04-18 16:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-14 18:03:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Craig 2000-03-01 08:36:25 UTC
"cvs release -d directory" aborts without waiting for the user specify
whether the directory should be released.  This failure is specific to
using ssh for connecting the to the server.  Here's an example session:

8 sparta /usr/src/SJS > cvs release -d verify
You have [0] altered files in this repository.
Are you sure you want to release (and delete) directory `verify': **
`release' aborted by user choice.
9 sparta /usr/src/SJS > env | grep CVS
CVS_RSH=ssh
CVSROOT=:ext:delphi:/home/cvsroot

I did a search of the news groups at deja, and a SSH newsgroup mentions
that the CVS server on RH 6.1 is reopening stdout, so sshd terminates the
session.

Comment 1 Cristian Gafton 2000-03-04 18:18:59 UTC
jim, can you please take a look at this?

assigned to kingdon

Comment 2 Stephen John Smoogen 2003-01-25 04:19:00 UTC
Does this bug still affect Red Hat Linux 7.3/8.0 with a newer version of CVS and
ssh?

Comment 3 Jay Turner 2003-04-14 18:03:55 UTC
Closing out due to bit-rot.


Note You need to log in before you can comment on or make changes to this bug.