Bug 988216 - Transformation configuration does not work properly
Transformation configuration does not work properly
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.0.0 GA
Unspecified Unspecified
urgent Severity urgent
: ER7
: 6.0.0
Assigned To: Jiri Pechanec
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 02:41 EDT by Jiri Pechanec
Modified: 2014-06-16 19:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
SwitchYardModelUtils.getServiceInterface() is using new QName() instead of QName.valueOf() to create the QName objects for ESB operation types. The result of this is that users cannot properly configure transformations in SwitchYard tooling because it mistakenly reports that no transformations are necessary.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproducer (4.60 KB, application/x-compressed-tar)
2013-09-18 02:45 EDT, Jiri Pechanec
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SWITCHYARD-1661 Major Closed Transformation configuration does not work properly 2015-08-11 04:31:20 EDT

  None (edit)
Description Jiri Pechanec 2013-07-25 02:41:48 EDT
I have found at least two examples when I cannot properly configure transformations in SY tooling because it mistakenly reports that no transformations are necessary.

1)
 - Take transform-json QS.
 - Manually remove configure transformations fro switchyard.xml
 - Import the QS into the tooling
 - Try to re-create transformations from tooling

2)
 - Create a Camel service that has an ESB-interface with non-Java input time
 - Create a bean service that has named @Reference to another service (Java-interface)
 - Wire the bean service with Camel service
 - Try adding transformation so bean service and Camel service can communicate

In both cases when the sy.xml is manually edited the cases works nicely.
Comment 1 Rob Cernich 2013-08-23 18:13:54 EDT
I think these are two different issues.

The first issue is because there are no required transformations required for the application.  I agree that this is a deficit in the tooling and we should allow users to create transformers for random types.

I cannot reproduce the second issue, so I will need more detailed steps to reproduce.  Here's what I tried:
1. Create a Java component.
2. Add a reference to the component created in step 1.
3. Create a Camel component, which implements an ESB interface whose service name matches the reference added in step 2.  The camel component's service should be automatically wired to the bean component's reference upon completion.
4. An error should appear stating that a transformer is required.  A walk through the wizard brought up by "create required transformers" creates and adds the transformers to the application and the error disappears.

Rob
Comment 2 Jiri Pechanec 2013-09-06 03:47:02 EDT
I tried the steps described by Rob and it does not work for me. No error appears and no wizard is started - I think we need to do a VNC session to demonstrate the issue
Comment 3 Rob Cernich 2013-09-17 09:23:12 EDT
Jiri, could you please attache the project you are testing with?  Thanks.
Comment 4 Jiri Pechanec 2013-09-18 02:45:46 EDT
Created attachment 799127 [details]
Reproducer

Project attached - see that reference and service have incompatible interfaces but no transformation is required according to JBDS
Comment 6 JBoss JIRA Server 2013-09-30 13:09:55 EDT
Brian Fitzpatrick <bfitzpat@redhat.com> made a comment on jira SWITCHYARD-1661

Ok, so there are two pieces to this issue it seems.

One, users should be able to add transformers even if they're not required. At one point we had that functionality, but we removed it in favor of the wizard-based required approach. We'll see what we can do to add that ability back in.

Two, I'm able to somewhat reproduce the issue Jiri is seeing with the sample project he posted. Thanks for that. Even if I add two JSON transformers to "match" the missing ones:

{code}
  <transforms>
    <transform:transform.json from="java:java.lang.Integer" to="{urn:my:servive}in"/>
    <transform:transform.json from="{urn:my:servive}out" to="java:java.lang.String"/>
  </transforms>
{code}

I'm still getting validation errors here, so I need to dig deeper and see what's going on.
Comment 7 Rob Cernich 2013-09-30 14:14:34 EDT
(In reply to JBoss JIRA Server from comment #6)
> Brian Fitzpatrick <bfitzpat@redhat.com> made a comment on jira
> SWITCHYARD-1661
> 
> Ok, so there are two pieces to this issue it seems.
> 
> One, users should be able to add transformers even if they're not required.
> At one point we had that functionality, but we removed it in favor of the
> wizard-based required approach. We'll see what we can do to add that ability
> back in.
> 

This would be an enhancement, which should be tracked in a separate issue.  At this point in time, I think that would be out of scope for GA, but once the other issue is created, we can let PM, QA and DEV decide when it needs to be addressed.
Comment 8 Anne-Louise Tangring 2013-10-01 09:57:50 EDT
From Rob, if you re-validate, you still get the errors, but it doesn't prevent you from deploying and running.

From ALT: Please split into two Bugzillas.
Comment 9 JBoss JIRA Server 2013-10-01 10:55:48 EDT
Rob Cernich <rcernich@redhat.com> made a comment on jira SWITCHYARD-1661

Looks like SwitchYardModelUtils.getServiceInterface() is using new QName() instead of QName.valueOf() to create the QName objects for ESB operation types.
Comment 10 Jiri Pechanec 2013-10-02 01:21:35 EDT
Feature request moved to bz1013997

(In reply to Anne-Louise Tangring from comment #8)
> From Rob, if you re-validate, you still get the errors, but it doesn't
> prevent you from deploying and running.
> 
> From ALT: Please split into two Bugzillas.
Comment 11 JBoss JIRA Server 2013-10-02 17:00:36 EDT
Brian Fitzpatrick <bfitzpat@redhat.com> made a comment on jira SWITCHYARD-1661

Implemented Rob's fix in this PR
Comment 12 JBoss JIRA Server 2013-10-04 13:59:31 EDT
Rob Cernich <rcernich@redhat.com> made a comment on jira SWITCHYARD-1661

pushed
Comment 16 Andrej Podhradsky 2014-01-22 04:43:49 EST
Verified with JBDS-IS 7.0.0.CR2. 

Note that adding transformations for the same types is reported at https://bugzilla.redhat.com/show_bug.cgi?id=1013997
Comment 17 JBoss JIRA Server 2014-06-16 19:47:45 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1661 to Closed

Note You need to log in before you can comment on or make changes to this bug.