Bug 988220 - mediawiki configuration fails with "Could not open /var/www/wiki/maintenance/tables.sql" error message
mediawiki configuration fails with "Could not open /var/www/wiki/maintenance/...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mediawiki (Show other bugs)
19
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michael Cronenworth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 02:56 EDT by Dhiru Kholia
Modified: 2014-03-24 23:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: mediawiki-1.21.1-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 20:24:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dhiru Kholia 2013-07-25 02:56:59 EDT
Description of problem:

mediawiki configuration fails with "Could not open /var/www/wiki/maintenance/tables.sql" error message.

Version-Release number of selected component (if applicable):

mediawiki-1.21.1-3.fc19.noarch

How reproducible:

Install mediawiki and try to configure it by accessing "http://localhost/wiki". 

It fails with "Could not open /var/www/wiki/maintenance/tables.sql" error message when it tries to do database stuff towards the end.

Here is a simple fix,

sudo ln -s /usr/share/mediawiki/maintenance /var/www/wiki/maintenance

Pushing this fix shouldn't be a problem since "/var/www/wiki" is already full of such symlinks.
Comment 1 Fedora Update System 2013-07-27 12:48:17 EDT
mediawiki-1.21.1-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mediawiki-1.21.1-4.fc19
Comment 2 Fedora Update System 2013-07-28 20:29:07 EDT
Package mediawiki-1.21.1-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mediawiki-1.21.1-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13806/mediawiki-1.21.1-4.fc19
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-08-05 20:24:03 EDT
mediawiki-1.21.1-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.