Bug 988231 - GDM fails to start because of journal
GDM fails to start because of journal
Status: CLOSED DUPLICATE of bug 967521
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 03:16 EDT by Till Maas
Modified: 2013-10-15 09:15 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-06 08:45:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of journalctl -b (203.86 KB, text/plain)
2013-08-15 17:54 EDT, L.L.Robinson
no flags Details
Output of "systemd-analyze plot" of system with /var/log/journal (93.76 KB, image/svg+xml)
2013-09-05 20:11 EDT, Tom London
no flags Details
Output of "systemd-analyze plot" of system without /var/log/journal (74.95 KB, image/svg+xml)
2013-09-05 20:12 EDT, Tom London
no flags Details

  None (edit)
Description Till Maas 2013-07-25 03:16:43 EDT
Description of problem:

On Fedora 19, sometimes GDM refuses to start on bootup but it works after removing /var/log/journal. Other people have similar problems:
http://www.linuxquestions.org/questions/fedora-35/fedora-boot-problem-4175468468/

It is not clear what lead to this error, but the X log file for GDM mentions an IO Error 11, but does not specify for which resource.
Comment 1 Michal Schmidt 2013-07-25 07:18:55 EDT
Do you use the btrfs filesystem?
Comment 2 Till Maas 2013-07-25 07:39:11 EDT
(In reply to Michal Schmidt from comment #1)
> Do you use the btrfs filesystem?

No.
Additional information: It is a system upgraded from F18 to F19 and the bug appeared recently.
Comment 3 Till Maas 2013-07-25 07:39:52 EDT
Also after logging in as root and running "systemctl restart gdm", gdm started without problems.
Comment 4 Till Maas 2013-07-26 03:50:04 EDT
this might be a duplicate of bug 987242
Comment 5 Lennart Poettering 2013-08-06 10:56:23 EDT
Please provide the output of "journalctl -b" when this happens and attach it to this bug!
Comment 6 Till Maas 2013-08-06 11:44:47 EDT
(In reply to Lennart Poettering from comment #5)
> Please provide the output of "journalctl -b" when this happens and attach it
> to this bug!

I believe the broken journal was deleted, therefore the error cannot reproduced on the affected system.
Comment 7 L.L.Robinson 2013-08-15 17:54:04 EDT
Created attachment 787071 [details]
output of journalctl -b

I had this issue, I ran journalctl -b and save the output. removing the /var/log/journal directory solved the boot timeout issue for me as well. Hope it helps
Comment 8 Scott Schmit 2013-08-16 07:43:21 EDT
FWIW, bug 985038, bug 967521, bug 970801, and bug 987242 are all duplicates.

In my case, it started after a Fedora 18 -> 19 upgrade.

Thanks for your attention to this issue.
Comment 9 Tom London 2013-09-05 20:10:40 EDT
I'm noticing "boot slow down" when journaling is enabled and when /var/log/journal exists.

I attach below plots from "systemd-analyze plot" for 2 consecutive boots (same kernel, same packages, same ...), the only difference being that I moved /var/log/journal to /var/log/journal.old.

The difference was striking: the first boot (with journal) took 46 seconds; the second boot (with journal moved to journal.old) took 22 seconds.

Although the first plot shows the "missing 24 seconds", I can't figure out where the time went.

Besides this (graphical) output, what info can I provide that would be helpful?
Comment 10 Tom London 2013-09-05 20:11:54 EDT
Created attachment 794548 [details]
Output of "systemd-analyze plot" of system with /var/log/journal
Comment 11 Tom London 2013-09-05 20:12:28 EDT
Created attachment 794549 [details]
Output of "systemd-analyze plot" of system without /var/log/journal
Comment 12 Harald Hoyer 2013-09-06 00:53:44 EDT
(In reply to Tom London from comment #10)
> Created attachment 794548 [details]
> Output of "systemd-analyze plot" of system with /var/log/journal

Wow.. please boot with "systemd.log_level=debug" on the kernel command line.
Then, when you are booted attach the output of:

# journalctl -o short-monotonic -ab
Comment 13 Harald Hoyer 2013-09-06 00:56:36 EDT
oh, btw, are you running on a 32bit or 64bit kernel?
Comment 14 Harald Hoyer 2013-09-06 02:10:26 EDT
pushed some journal fixes in systemd-206-11
Comment 15 Zbigniew Jędrzejewski-Szmek 2013-09-06 08:45:51 EDT
Similar issue with plymouth-quit-wait.service failing happens here too. Probably removing the journal directory un-triggers the race condition between plymouth and gdm, and is not the real issue.

*** This bug has been marked as a duplicate of bug 967521 ***
Comment 16 Tom London 2013-09-06 09:13:58 EDT
(In reply to Harald Hoyer from comment #13)
> oh, btw, are you running on a 32bit or 64bit kernel?

64 bit: kernel-3.12.0-0.rc0.git11.2.fc21.x86_64

Believe this has been occurring for quite some time however (months...).
Comment 17 Frank Murphy 2013-10-15 04:01:07 EDT
I am having this on F20, 
and plymouth is not installed
No btrfs
Xfce fully updated, lightdm.
Comment 18 Frank Murphy 2013-10-15 09:15:31 EDT
(In reply to Frank Murphy from comment #17)
> I am having this on F20, 
> and plymouth is not installed
> No btrfs
> Xfce fully updated, lightdm.

Apologies, ignore above. added to wrong bz.

Note You need to log in before you can comment on or make changes to this bug.