Bug 988257 - polymake-2.12-8.fc20 does not build with perl 5.18
polymake-2.12-8.fc20 does not build with perl 5.18
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: polymake (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
http://forum.polymake.org/viewtopic.p...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 04:13 EDT by Petr Pisar
Modified: 2013-08-20 15:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 15:39:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2013-07-25 04:13:47 EDT
Current polymake fails to build against perl 5.18 due to changes in perl 5.18 API <https://koji.fedoraproject.org/koji/taskinfo?taskID=5653172>:

namespaces.xs: In function 'boot_namespaces':
/usr/lib/perl5/CORE/av.h:62:26: error: 'PADLIST' has no member named 'sv_u'
 #define AvARRAY(av) ((av)->sv_u.svu_array)

It has been fixed by upstream with SVN commit 11273 allegedly <http://forum.polymake.org/viewtopic.php?f=10&t=338>, but I cannot find the upstream SVN repository anywhere.

You could use patch from different project probably <https://rt.cpan.org/Public/Bug/Display.html?id=79182>.
Comment 1 Jerry James 2013-07-30 13:22:58 EDT
(In reply to Petr Pisar from comment #0)
> It has been fixed by upstream with SVN commit 11273 allegedly
> <http://forum.polymake.org/viewtopic.php?f=10&t=338>, but I cannot find the
> upstream SVN repository anywhere.

It's a private repository.  They push some of their changes to a public "beta release" SVN repository, but I don't see this particular commit in that repository.

> You could use patch from different project probably
> <https://rt.cpan.org/Public/Bug/Display.html?id=79182>.

Thanks for the link.  I'll see if I can figure out the appropriate fix.
Comment 2 Jerry James 2013-08-20 15:39:00 EDT
I have built the latest polymake "public beta", which includes fixes for perl 5.18.

Note You need to log in before you can comment on or make changes to this bug.