Bug 988260 - password.py: "set_admin_password" action will execute again when clicking "Enter"
password.py: "set_admin_password" action will execute again when clicking "En...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.3
Unspecified Unspecified
medium Severity medium
: ---
: 3.4.0
Assigned To: Fabian Deutsch
Barak Dagan
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 04:20 EDT by haiyang,dong
Modified: 2014-07-13 19:19 EDT (History)
14 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-31 08:30:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot (11.83 KB, image/png)
2013-07-25 04:20 EDT, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2013-07-25 04:20:34 EDT
Created attachment 778108 [details]
attached Screenshot

Description of problem:
Using "/usr/libexec/ovirt-config-password" tool to execute "set_admin_password"
after setting admin password successfully, then clicking "Enter",
this tools will execute "set_admin_password" action again.(Seen set_admin_password.png)
Actually, we hope this tools just prompt ">" to users. 

Version-Release number of selected component (if applicable):
http://resources.ovirt.org/releases/3.3/iso/ovirt-node-iso-3.0.0-5.0.3.vdsm.fc19.iso
ovirt-node version:ovirt-node-3.0.0-5.0.fc19.noarch

How reproducible:
100%

Steps to Reproduce:
1. Using "/usr/libexec/ovirt-config-password" tool to execute "set_admin_password"
2. After setting admin password successfully, then clicking "Enter".

Actual results:
"set_admin_password" action will execute again when clicking "Enter" 

Expected results:
Actually, we just hope this tools just prompt ">" to users when clicking "Enter". 

Additional info:
Comment 1 Sandro Bonazzola 2014-01-27 08:51:07 EST
This should be fixed in oVirt 3.4.0 beta1 build
Comment 2 Barak Dagan 2014-02-25 11:07:27 EST
verified on: oVirt Node Hypervisor release 3.0.3 (0.999.201401221941draft.el6)


> admin

 Password Configuration

System Administrator (admin):

Changing password for user 'admin'.
New password: 
Retype new Password: 
[WARNING] You have provided a weak password! Strong passwords contain a mix of uppercase, lowercase, numeric and punctuation characters. They are six or more characters long and do not contain dictionary words. Reason: it is WAY too short
[INFO] Password updated successfully.
> q
Comment 3 Sandro Bonazzola 2014-03-31 08:30:10 EDT
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released

Note You need to log in before you can comment on or make changes to this bug.