Bug 988277 - freerdp missing alsa plugin
freerdp missing alsa plugin
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: freerdp (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Søren Sandmann Pedersen
Desktop QE
:
Depends On:
Blocks: 988308
  Show dependency treegraph
 
Reported: 2013-07-25 04:53 EDT by Tomas Pelka
Modified: 2014-06-18 05:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
The ALSA plug-in is not supported in Red Hat Enterprise Linux 6. Instead of the ALSA plug-in, use the pulseaudio plug-in. To enable it, use the --plugin rpdsnd option with the xfreerdp command without specifying which plug-in should be used; the pulseaudio plug-in will be used automatically in this case.
Story Points: ---
Clone Of:
: 988308 (view as bug list)
Environment:
Last Closed: 2013-11-21 06:38:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2013-07-25 04:53:28 EDT
Description of problem:
freerdp missing ALSA plugin obviously

Version-Release number of selected component (if applicable):
freerdp-plugins-1.0.2-1.el6
freerdp-debuginfo-1.0.2-1.el6
freerdp-1.0.2-1.el6
freerdp-libs-1.0.2-1.el6

How reproducible:
100%

Steps to Reproduce:
1. xfreerdp -u administrator -p RedHat1! --plugin rdpsnd --data alsa --  lab-winxp-1.gsslab.rdu2.redhat.com
2.
3.

Actual results:

loading plugin rdpsnd
connected to lab-winxp-1.gsslab.rdu2.redhat.com:3389
freerdp_load_library_symbol: failed to open /usr/lib64/freerdp/rdpsnd_alsa.so: /usr/lib64/freerdp/rdpsnd_alsa.so: cannot open shared object file: No such file or directory
freerdp_load_plugin: failed to load rdpsnd_alsa/FreeRDPRdpsndDeviceEntry


Expected results:


Additional info:
Comment 3 Tomas Pelka 2013-07-31 14:54:26 EDT
Soren we can close this bz in case we document it somewhere.
Comment 4 Søren Sandmann Pedersen 2013-08-08 10:03:25 EDT
Marking as MODIFIED -- there are no code changes for this bug, just the addition of a "known issue" bit of documentation.
Comment 7 errata-xmlrpc 2013-11-21 06:38:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1625.html

Note You need to log in before you can comment on or make changes to this bug.